Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Low level stims falling off after death in PvP?

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Low level stims falling off after death in PvP?

MichaelKLee's Avatar


MichaelKLee
11.15.2015 , 11:06 AM | #1
So recently, I decided to give my lower level character the purple stims for pvp purposes since they last for 8 hours.

Unfortunately, the level 26 stims, Advanced Bio-Enhanced Versatile Stim, are falling off during pvp for one reason or another, I believe due to death. They clearly state that they are supposed to persist through defeat.

I was wondering if there was any information on this.

I tested on characters I transferred and ones I didn't and it happened to both. So I don't think that is the cause. Others have tested some low level ones for me and not noticed the effect, though I don't believe the level 26 ones were what they tested, leading me to believe it is with this particular item.

Thanks for any help you can provide.

TwoLekku's Avatar


TwoLekku
11.27.2015 , 12:47 PM | #2
Quote: Originally Posted by MichaelKLee View Post
So recently, I decided to give my lower level character the purple stims for pvp purposes since they last for 8 hours.

Unfortunately, the level 26 stims, Advanced Bio-Enhanced Versatile Stim, are falling off during pvp for one reason or another, I believe due to death. They clearly state that they are supposed to persist through defeat.

I was wondering if there was any information on this.

I tested on characters I transferred and ones I didn't and it happened to both. So I don't think that is the cause. Others have tested some low level ones for me and not noticed the effect, though I don't believe the level 26 ones were what they tested, leading me to believe it is with this particular item.

Thanks for any help you can provide.
Same. I didn't go to many lengths to test which stims, because a stim that says it persists through death should persist through death. It happened on 3 different stims today, two of which were purple. I'll let whoever made this error spend their time investigating its breadth. Dear Bioware. Please fix. I'm not spending mats to figure out more about why this broke.