Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Multiple SWTOR Errors

--Alerion--'s Avatar

03.17.2012 , 10:26 AM | #1
Hello, I see there has been some issues going on with patching, or launcher errors for quite a hand full of people. I have a similar issue, though it doesn't seem to involve anything to do with a patch.

I recently tried to log in: I opened my launcher menu, entered my password, and security code correctly then the client went into a long period of loading which it has never done for me before. After about a 3-4 minute loading time the launcher read "Log in service is currently unavailable at this time--"

So I exited the launcher, then tried again: This time I was able to log into the next page of the launcher. However, it took a good few minutes for "Play" to become available for me. As it eventually did I clicked it, and began to load into the game. Now at this point I was stuck on the first loading screen for about 10 minutes waiting for something, but it never progressed. The screen was not frozen because the loading animation at the bottom right of the screen was rotating smoothly as usual, just no progression passed that screen.

And once more: I exited the game, and tried again only to run into "Log in service is currently unavailable at this time--" for a second time.

--Alerion--'s Avatar

03.17.2012 , 10:35 AM | #2
--And never mind, seems to be working fine now. That was just an odd scare, hm.