Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Please fix gosh darn stealth and force cloak

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Please fix gosh darn stealth and force cloak

Tobeass's Avatar

04.01.2014 , 01:33 PM | #1
Stealth and Force Cloak gotta be the most buggiest gosh darn abilities to ever exist in a RPG game. Stealth keeps turning itself off, usually at the worst possible times, like when you're sneaking past someone or something you cannot be arsed to fight. And force cloak is supposed to end combat. 9/10 times it does not, or bugs the hell up. Especially when you got a companion.

Loc_n_lol's Avatar

04.01.2014 , 01:42 PM | #2
Stealth isn't 100% foolproof, enemies (both players and npcs) can still spot you at close range, especially in their forward view cone. All stealth classes have an ability that increases their stealth level temporarily, this is usually enough to make you completely invisible for the duration, even at point-blank range (exceptions being enemies with enhanced stealth detection).

Any damage or healing done to a character in combat will put you in combat, so even though stealth breaks combat, having DoTs or HoTs on a target means you will go back into combat as soon as they tick. Many companions have some form of bleed/burn ability and will use it on cooldown, so this could be what you're seeing here.

Taking damage while stealthed will remove you from stealth (and put you back into combat). If you have any DoTs on yourself or your companion, you won't get away, you need to remove those effects.

Tobeass's Avatar

04.01.2014 , 02:49 PM | #3
I am aware that stealth does not make me 100% invisible. But if you've ever used it yourself, you will know that it turns it self off for no reason what so ever at random spots, without getting detected or attacked at all. Both force cloak and stealth is extremely glitchy, and is generally a pain in the arse to use. And yes, I've spoken with other people about this, they've noticed the same things.

Daewan's Avatar

04.01.2014 , 03:56 PM | #4
I only have a problem with certain droids. Every other time stealth has broken, it has been for an obvious reason. Can you provide some more concrete examples, like what level you are and what you are trying to sneak past when it goes off?
Darth Squeek, Dark Lord of the Skittles, Revan Fanboy
<< Derp :: Questions about SWTOR? SEARCH DULFY! :: Obligatory referral link: ::
Quote: Originally Posted by Alssaran View Post
Would you care to show me where the evil Bioware touched you? Possibly on this anatomically correct "SonofThulkose" doll?

Loc_n_lol's Avatar

04.01.2014 , 06:54 PM | #5
Yeah, that sounds like you've just walked into a stealth scan droid...

Tobeass's Avatar

04.02.2014 , 03:31 AM | #6
I'm level 55, and it happens all the time. Walked into a stealth scan droid? No. This doesn't >always< happen around enemies. Often stealth disables itself close to enemies, but still not close enough for them to notice or attack me after stealth has turned itself off. I'll see if I can get a recording of it.

Never_Hesitate's Avatar

04.02.2014 , 04:11 AM | #7
Quote: Originally Posted by Tobeass View Post
This doesn't >always< happen around enemies. Often stealth disables itself close to enemies, but still not close enough for them to notice or attack me after stealth has turned itself off. I'll see if I can get a recording of it.
That sounds exaclty like the doing of an enemy with stealth scan
waiting for ...

docbenwayddo's Avatar

04.02.2014 , 05:04 AM | #8
There are some areas, without scanning droids, that will pop you out of stealth. One I know for sure is in Talaos City.

By doing Signal Intelligence before Taking Back Talaos, you trigger a bonus using the Flaregun you get in it to call in reinforcements at 4 corners round the "city block" that you climb to scan the bonus turret. Whether this bonus objective is active or not, passing through any of the four corners of this block will break stealth.

If the bonus is active, you will see the flaregun in Mission Tracker light up as clickable at the moment stealth drops.

I'm guessing, if there are no scanning droids around, this sort of triggered area stealth dampening might be the culprit.
Try using your rocket boost to go down the stairs from the Westwater Settlements platform where the Imperial taxi is, into the field with the hovertanks. Arriving at the bottom of the stairs will "dismount" your rocket boost even if you only activated it 5 stairs ago.