Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Camera Rotation Set to 0% and its still too fast?

STAR WARS: The Old Republic > English > PvP
Camera Rotation Set to 0% and its still too fast?

sabresandiego's Avatar


sabresandiego
03.04.2012 , 11:04 PM | #1
Does anybody else have this issue?
Sabrewolf - Battlemaster Jedi Sentinel on The Crucible Pits

Sabrelife - Scoundrel Healer on The Crucible Pits

SeanPoe's Avatar


SeanPoe
03.04.2012 , 11:10 PM | #2
Yup, i do. It's because Bioware decided to add a ridiculous amount of artificial camera acceleration (ie, the camera starts to turn faster the longer it's turning) just like every other game they've made to date. The dragon age series and even the Mass Effect series both have an extremely high level of mouse/camera acceleration.

I haven't figured out a way to remove it yet. Even if there was a game file you could edit to remove it, it would probably be against the ToS and every patch would just revert any changes you've made to the files anyways.

SeanPoe's Avatar


SeanPoe
03.04.2012 , 11:20 PM | #3
Double-posting to say, i found where the file is that you can edit:

Quote:
- I have gone into my SWTOR .INI file and set [ Controls_CameraRotationSpeed = 0.08 ]. When you set the camera rotation speed slider in game to 0%, it goes down to "0.1" at the minimum. You can get slower camera rotation speeds by modifying the file directly. Changing the slider and applying in game will overwrite this. However, I have already overwritten my previous settings with the in-game settings slider. This .INI file is located in ( C:\Users\%USER%\AppData\Local\SWTOR\swtor\settings \%ACCOUNTNAME%_Account.ini )
That's from this thread all about this issue.

MazokuRanma's Avatar


MazokuRanma
12.30.2015 , 04:03 AM | #4
I'm resurrecting a dead post, but I wanted to add to it as I'm having this issue after returning to the game, and this worked perfectly. My rotation was at 0%, and my Razer Synapse profile for SW:tOR was also at the lowest level possible, and still the slightest motion would rotate it far beyond what I intended. This file is still located in the same place, though you may need to add the line specified, as mine did not show it. Regardless, setting it to 0.06 worked perfectly for my system.

Draqsko's Avatar


Draqsko
12.30.2015 , 08:37 AM | #5
Quote: Originally Posted by MazokuRanma View Post
I'm resurrecting a dead post, but I wanted to add to it as I'm having this issue after returning to the game, and this worked perfectly. My rotation was at 0%, and my Razer Synapse profile for SW:tOR was also at the lowest level possible, and still the slightest motion would rotate it far beyond what I intended. This file is still located in the same place, though you may need to add the line specified, as mine did not show it. Regardless, setting it to 0.06 worked perfectly for my system.
Mouse acceleration for Razer is a combination of Synapse acceleration and dpi, Windows mouse acceleration, and the in game acceleration.

Turn down pointer speed in Windows mouse pointer options, and disable enhance pointer precision (this has the effect of increasing acceleration the farther you move the mouse, reducing your control). For 3600 dpi, I set the pointer speed at the halfway point, but at 8200 dpi I have to set the speed at the second lowest setting. And this is with 0 acceleration in Synapse.

I can't remember what I had to do for in game acceleration at high dpi, but it still felt like I was losing control at various points so I switched back to 3600 dpi with 50% acceleration in Windows and games, and 0 acceleration in Synapse. That seems to offer the best control to me, but all three settings will affect camera and pointer speed so you'll have to play with them to find the point where everything works the best for you.

Ruletide's Avatar


Ruletide
09.11.2016 , 11:50 PM | #6
Resurrecting this again, 9/12/16 for another input. The issue is ~still~ there. The variable setting in (on my computer), C:\This PC\Users|Owner|AppData\Local|SWTOR\swtor\settings\ YOURLEGACYNAME_Account.ini called (default) Controls_CameraRotationSpeed = 3.09999990463 had to be reduced to 0.57 in order to prevent instantaneous camera excursions that force the screen view into full top down or under floor up, when adjusting camera pitch. ("Pitch" = depress and hold mouse button 2 and then move the mouse in order to change perspective from higher above and behind toon (third person view) to lower, or vice versa.) This seems less an issue of mouse pointer speed and more one camera pitch speed. In any event, the fixed variable works to adjust the insidious "I'm suddenly looking down at the top of my toon's head" problem, as well as others above.

Ruletide

NOFpuXnk's Avatar


NOFpuXnk
05.06.2017 , 09:54 PM | #7
bump.......................

Liquor's Avatar


Liquor
05.07.2017 , 07:11 PM | #8
Thanks. This post had slipped by me. On a different rig now due to a GPU fail. Subbed for future reference.

...
Still works

Echu's Avatar


Echu
11.18.2017 , 03:19 PM | #9
Resurrecting this post again. 2 days ago came this to me, suddenly and I didn't do anything with swtor preferences. And several on my guild happen to have same bug also since a few days ago. Incredible this bug still exists since 2012
Guild Leader since 2006
Promoting game since Beta
Expecting new Endgame Content
Getting bored of repeating same ops for 3 years

Raansu's Avatar


Raansu
11.18.2017 , 11:36 PM | #10
0% has always been too high for me. I have razer synapse lower the dpi when swtor.exe is launched.