Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Stuck on Class Quest: Clan Ordo

STAR WARS: The Old Republic > English > Classes
Stuck on Class Quest: Clan Ordo

WayneInAustin's Avatar

02.08.2012 , 02:52 PM | #1
Edited: Never mind - This is actually a bug. The problem is that the item to click on is NOT VISIBLE, but is nevertheless there. The item is not on top of the tower but on the ground on a rock or piece of ruin, just like the other quest items... only on my screen it was not visible...but the mouse icon changed when I moused over the rock, so I was able to complete.

I think this is probably a case where I'm just blind and missing something obvious, but I'm stuck on the quest "Geroya be Haran: Capture Jicoln's Oath to Clan Ordo". The quest symbol (green triangle) seems to indicate the item is inside (or on top of?) a large round toppled tower next to the medical center. I've been all around the tower and could not find any way into it. There is one spot where there are some rectangular holes that seem to lead in, but they are just high enough that I can not jump into them. Tried for about 10-15 minutes at all angles. I even tried going into the hospital to see if there was some way to jump over, but not there or I missed it.
Am I making this way more difficult than it is?
Any info appreciated.

TempestasSilva's Avatar

02.08.2012 , 05:20 PM | #2
I remember both of those, but I don't remember the answer. I'm so sorry, but I fail.
Devs: Please make healing more interesting and fun by increasing options and meaningful decisions. Let a good healer be judged by the decisions they make, not who pressed the buttons in a certain order. Or which class has the most output.

jrandalh's Avatar

02.20.2012 , 12:38 AM | #3
Thank you for the update. I am having the same issue myself.

cesmode's Avatar

02.22.2012 , 07:14 PM | #4
your post helped me. thanks

LordXayd's Avatar

02.28.2012 , 04:46 PM | #5
The quest clicky is a mostly cube shaped boulder (about half a character height) right where the icon indicates (in the grass, not on top of the tower). The problem is the boulder is not lit up.
To everyone that feels like flaming me, I don't care. The forums were put up so prematurely before game release that every thought has been expressed a thousand times over, and I don't feel like reading the 1000 prior threads to ensure they aren't an exact match for mine.

DocsMysticalBay's Avatar

03.26.2012 , 05:19 PM | #6
Thanks for the update. I was having the same issue...found your post very helpful.

DisneyGeek's Avatar

05.02.2012 , 08:06 PM | #7
Another THANK YOU! I too had the invisible class item here...

sakshale's Avatar

01.11.2014 , 06:59 PM | #8
And yet another thank you... and a "blat" to the support team that doesn't seem to be able to fix this simple thing.
Hokey religions and ancient weapons are no match for a good blaster at your side.

winsorcat's Avatar

01.02.2015 , 11:47 PM | #9
Thank you very much. I searched for 2 hours for this before resorting to looking it up. Your post helped me find it in 3 min.

Gonalius's Avatar

08.24.2015 , 01:13 PM | #10
Another bump, another thank you. I spent about 10 minutes trying to find a way onto the round platform before searching the net for an answer... A bug... Bah! Bah I say!