Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Stuck on Class Quest: Clan Ordo

STAR WARS: The Old Republic > English > Classes
Stuck on Class Quest: Clan Ordo

DeaconX's Avatar

11.24.2015 , 10:28 PM | #11
3 years later, object is still not flashing for the quest.

Good thing I found this thread though!
The best work never was and never will be done for money.

Carsti's Avatar

01.13.2016 , 04:25 PM | #12
Meanwhile with have 2016 and this bug is still there. Normally I do not venture into comparing ST:TOR and WOW, but something Blizzard did much, much better is actually fixing bugs. Mind you: fixing. They had bugs too, no question about that, but having it still after some howmany years for crying out loud?

tjohnbeattie's Avatar

09.20.2016 , 01:32 PM | #13
hard to believe it after so long but still not fixed - ty for post - had already wasted 15 minutes on this before checking this post.

Hockster's Avatar

11.10.2016 , 03:11 PM | #14
So yeah, this *still* hasn't been addressed. Glad Google found this thread.

LorcaGneditch's Avatar

12.25.2016 , 06:25 AM | #15
Still nothing. Thank gosh this thread exists.
Really, is this THAT hard to fix?

CGJannek's Avatar

04.09.2017 , 03:37 AM | #16
Thank god for this hint, never would've found it!
And yeah, April 2017, stupid boulder still not lit!

Arigas's Avatar

10.23.2017 , 10:24 AM | #17
Only reason I found the bloody thing. Kind of annoyed its not fixed after so long.

LacroNOIR's Avatar

01.07.2018 , 04:51 AM | #18
Thx, very helpful information. Spent much time untill found this theme.

XavierY's Avatar

03.19.2019 , 08:16 PM | #19
Quote: Originally Posted by WayneInAustin View Post
Edited: Never mind - This is actually a bug. The problem is that the item to click on is NOT VISIBLE, but is nevertheless there. The item is not on top of the tower but on the ground on a rock or piece of ruin, just like the other quest items... only on my screen it was not visible...but the mouse icon changed when I moused over the rock, so I was able to complete.
Thank you.