Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Post Windows 10 Update problem

First BioWare Post First BioWare Post

XzioTheFey's Avatar


XzioTheFey
06.18.2017 , 06:26 AM | #51
I'm having the same issue as well. I have to relaunch the game 4 or 5 times before it will let me play. I've tried repairs, updating drivers, and reinstalling and nothing seems to help.

XzioTheFey's Avatar


XzioTheFey
06.18.2017 , 06:30 AM | #52
Quote: Originally Posted by EricMusco View Post
Hey folks,

A few updates on this situation. For players that have updated Windows 10 to the Creator Edition, they can experience an issue in SWTOR that causes a crash to desktop. This seems to be primarily caused by being alt-tabbed out of the game and focusing on another window while SWTOR is open and loading.

The team is looking into fixing the problem and I will pass on updates as I have them. In the meantime there are three workarounds which have had some success.
1) Disable vsync on your video card.
2) Disable Game Mode in Windows.
3) In Windows, disable the full-screen optimization option for SWTOR.

I will pass on more information as I have it.

-eric
EricMusco, are there any updates on this?

Martyha's Avatar


Martyha
06.23.2017 , 03:35 PM | #53
When you get to the character screen, click alt+enter and wait for the screen to refresh, then you are good to go. It works for me. It works both ways: when the game is full-screen and alt+enter switches it into a window mode, and the other way around.
I am waiting for an official fix, but for now I am able to log in with this trick.

Kyuuu's Avatar


Kyuuu
07.16.2017 , 11:29 AM | #54
Code:
2017-07 Cumulative Update for Windows 10 Version 1703 for x64-based Systems (KB4025342)
THis fix the issue with Swtor Crashing due to tabing out before fulling loading a character for first time. I can once again tab out alli want before loading character for first time.

The Coremessaging.dll was causing similar crashes in other 32bit programs on 64bit OS in similar situations

BarryGK's Avatar


BarryGK
07.16.2017 , 01:42 PM | #55
Just a follow-up concerning my situation..this may not be the case for everyone, but since 5.3, I am no longer having the issues with the game crashing at character selection screen.
Anjeal Torvin

OwenBrooks's Avatar


OwenBrooks
07.17.2017 , 07:03 AM | #56
Kyuuu is correct

The July 11, 2017—KB4025342 (OS Build 15063.483) patch at this link was the MS fix applied to stop swtor crashing on launch

Addressed issue with CoreMessaging.dll that may cause 32-bit apps to crash on the 64-bit version of the Windows OS.

Wigetts's Avatar


Wigetts
07.19.2017 , 04:39 PM | #57
I just sub/ the game, have been having launcher issues, i un-installed and reinstalled, now the game gets past the launcher.. but when i press play, my res. drops for my whole PC to 600 x 800 or something and the swtor.exe is min. to the taskbar, and it wont open. i have tried to find a client.ini file to make this open in a window mode, but there is no client settings file that i can find. HELP.

this should not be this difficult. imo. takes like an hour do download. i was playing a few night ago just fine, then the lanucher keep blowing up and i could not play, have uninstalled/installed like 4 times.

windows 10. 64 bit. all updates are current. nvidia 980 . the PC is a beast. i would like to get on my lvl 16 char and play some, but this has got me at my witts end.

OwenBrooks's Avatar


OwenBrooks
07.20.2017 , 02:58 AM | #58
Quote: Originally Posted by Wigetts View Post
but when i press play, my res. drops for my whole PC to 600 x 800 or something and the swtor.exe is min. to the taskbar, and it wont open..
Just press the ALT + Enter Keys after pressing play and it does that

Wigetts's Avatar


Wigetts
07.20.2017 , 04:30 AM | #59
Quote: Originally Posted by OwenBrooks View Post
Just press the ALT + Enter Keys after pressing play and it does that
thanks, finally got on the phone with support and they sent me an email with what to do, what to fix, .. i had to wait till the game fully downloaded, before the settings file/folder was present, then just matched the high/width to my current screen and was able to get on . but the alt-enter worked also. thanks.