Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Server Queue?

GregJr's Avatar


GregJr
06.19.2017 , 10:42 PM | #1
anyone else stuck in a queue again?

xeraphyne's Avatar


xeraphyne
06.19.2017 , 10:43 PM | #2
Quote: Originally Posted by GregJr View Post
anyone else stuck in a queue again?
Yep 103.. to 93... to 90.. back up to 93 :/
Seraphyne Sorc Heals | Minxy and Scrumptious Op Heals
Saraphyne Sage Heals

THE RAWR LEGACY
EVIL INTENTIONS | WORKING AS INTENDED
Help a girl out! You get free goodies!

GregJr's Avatar


GregJr
06.19.2017 , 10:45 PM | #3
Quote: Originally Posted by xeraphyne View Post
Yep 103.. to 93... to 90.. back up to 93 :/
its crazy they just did maintenance for this

drpwnsmith's Avatar


drpwnsmith
06.19.2017 , 11:02 PM | #4
Started out at 110. Thought for sure it was a glitch. Backed out, logged into Harbinger, got in no problem. Logged out, tried to get into Jedi Covenant again and now I'm up to 172!

mollymauler's Avatar


mollymauler
06.19.2017 , 11:04 PM | #5
I'm experiencing this RIGHT NOW. What should I do? I tried rebooting my CPU and ending/restarting the game multiple times. I have been reading about this issue but I cannot seem to find a way to "solve" it. ANY HELP would be greatly appreciated!

-molly

EDIT - I figured I should edit this and say that server time is 1:07 am. This started occurring at about 12:45 am server time.

EDIT#2 (1:26 am) - Upon trying again, I'm greeted with a screen that says "server offline." It's late and I am going to bed. I hope this is resolved in the morning when I try to log in.

blakthorn's Avatar


blakthorn
06.19.2017 , 11:44 PM | #6
Looks like all the EC servers are down........

GregJr's Avatar


GregJr
06.19.2017 , 11:59 PM | #7
typical.

mollymauler's Avatar


mollymauler
06.20.2017 , 08:47 AM | #8
Got up and saw that this issue was supposedly rectified. Tried to log in just now (10:44am server time) and now I get this -http://i.imgur.com/VYuVEBA.png

EDIT (11:20am) - in game now. haven't tried switching toons yet. If the issue happens when trying to switch, I'll update this thread.

lll_SYLER_lll's Avatar


lll_SYLER_lll
06.20.2017 , 09:28 AM | #9
Seems like servers are having an issue again....
Or at least Shadowlands, didn't check the rest of the East coast.