Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Latency

kayox's Avatar


kayox
12.25.2011 , 06:06 PM | #1
Game seems unplayable. I keep getting latency of over 9000!

I'm running a 12mbs connection and speed test is steady at that speed. Why are the servers running so slowly? It's really frustrating when you're paying premium prices for an MMO.

Doralol's Avatar


Doralol
12.25.2011 , 06:40 PM | #2
I believe i am getting the same thing, besides the fact that it doesnt say i have high ms. My ms is always at 80 but when i get into combat it just feels horrible.

Knigon's Avatar


Knigon
12.25.2011 , 07:01 PM | #3
Same here, not as bad as that though, but i was going from 30 to 6000 and sometimes getting dc'd. but i will give them the benifit and see how things pan out over the new couple of weeks as i have played a few games at launch and there are always issues, Just means i will play others games for abit.

Edit: I have now decreased my lag a little by going to my graphics card company web site and getting and manually installing all updated software and drivers and also opening all the ports for the game in the router (ports are 80, 8995, 12000-12999 and 20000-30000 (TCP - i just put both) you can get details and find your router at portforward.com - ps don't forget to make a static ip and check your ports are open after which you can do both using 2 of there programs on there site ) I also installed Leatrix Latency Fix

Knigon

(EDIT...READ YELLOW)

renegadeimp's Avatar


renegadeimp
12.25.2011 , 07:03 PM | #4
The latency is on your side or your ISP's side guys. If it was a server issue, then this forum would be flooded with posts about it.
Streamline - A guide to speeding up low - mid range Computer systems.
Latency Thread - Latency issue gathering thread..
Have a tech issue you need help with? You can nomally find me on the Customer Support forum.

Knigon's Avatar


Knigon
12.25.2011 , 07:09 PM | #5
yeah i found that out lol, after editing lots and trying things, still getting a few problems but i have listed what i have done above in yellow and that has helped me