Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Some tips about the "component deselect" bug

STAR WARS: The Old Republic > English > Galactic Starfighter
Some tips about the "component deselect" bug

Verain's Avatar


Verain
11.15.2019 , 05:48 PM | #1
The "component deselect" bug has been around since a specific patch that I forget (if someone would remember, it might help someone fix it later, maybe). But it's been around almost as long as GSF itself.

The "component deselect" bug is extremely hard for a given person to reproduce. It may be easy for you to reproduce, however- this thread is about making it happen less often.

The "component deselect bug" happens like this: you log on one day, and you check your ships. Mysteriously, your, say, ion railgun, has neither the tier 4 nor the tier 5 component selected. This happening to a five-upgrade-tier component is by far the most common version of this. Rarely, your minor component will come deselected. Very rarely (and likely not for years at this point), an entire weapon can come deselected.
-The deselect never happens while you are logged in, only once you have logged out
-The deselect often happens to the same component repeatedly

So, what's my advise here?

If you see component deselect on a given ship in a given hangar position more than once, move that ship to a different hangar position. So for instance, if your proton comes deselected on your Imperium sitting in the second spot, move it to the fifth spot, and see if it comes deselected there too. Try every spot! Keep notes!

This is not guaranteed to fix it- but for some of you, it will absolutely fix this problem. I have several characters who never see this problem (unless I change their hangar), but used to be plagued by it.
"The most despicable person on the GSF forum."

DakhathKilrathi's Avatar


DakhathKilrathi
11.15.2019 , 10:24 PM | #2
Wasn't there a worse version originally where you could have the entire component deselected? I feel like that was the case. The tier deselect bug was noticed after the patch that fixed that, if it helps.

I'll try and track down the patch in question tonight and see if I can find it. I might not be remembering right.

Edit: I was! I found my bug report thread on the original bug:

http://www.swtor.com/community/showthread.php?t=830482

and a thread where we talk about missing choices as part of the same bug:

http://www.swtor.com/community/showt...39#post8508839

Hope that helps.

HrRav's Avatar


HrRav
11.16.2019 , 04:51 AM | #3
It would be great if this bug was fixed. I have noted the following patterns of the bug:

1. It only affects the primary weapon.

2. It usually occurs if I log in after the daily reset. If I select the component again then it will almost always remain selected until next day.

3. It only affects ships that I have been flying before the daily rest. Thus, if I did not tuch my gunship the previous day then the components will remain selected.

4. My oldest toons (that I created before gsf launched) are raraley affected by the bug, whereas characters that I created later are affected every time I log in after a daily reset.

Toraak's Avatar


Toraak
11.16.2019 , 12:33 PM | #4
Quote: Originally Posted by HrRav View Post
It would be great if this bug was fixed. I have noted the following patterns of the bug:

1. It only affects the primary weapon.

2. It usually occurs if I log in after the daily reset. If I select the component again then it will almost always remain selected until next day.

3. It only affects ships that I have been flying before the daily rest. Thus, if I did not tuch my gunship the previous day then the components will remain selected.

4. My oldest toons (that I created before gsf launched) are raraley affected by the bug, whereas characters that I created later are affected every time I log in after a daily reset.
#1 is wrong. I've had it affect Secondary weapons (EMP Missiles, Proton Torpedoes, Ion railgun, and Slug railgun for some examples), as well as other components. One of my characters even has it happen on Tenser field.

#3 may be inconsistent then, because I see no difference if I fly before reset at all.
Referral Link: www.swtor.com/r/Q4Tp3P

Drakkolich's Avatar


Drakkolich
11.16.2019 , 07:49 PM | #5
Quote: Originally Posted by Toraak View Post
#1 is wrong. I've had it affect Secondary weapons (EMP Missiles, Proton Torpedoes, Ion railgun, and Slug railgun for some examples), as well as other components. One of my characters even has it happen on Tenser field.

#3 may be inconsistent then, because I see no difference if I fly before reset at all.
Let's maybe not say someone's wrong on reporting a bug, just because you're seeing different stuff doesn't necessarily mean his accounting is wrong, or even less useful. If some people are only seeing Primaries have the bug maybe that's a clue as to what's going on.

I myself have also had Primaries, Secondaries and Systems all get deselected. I find I have "problem components" that it happens too more often. For example I have like 5 characters that the Burst Laser Cannons on the Mangler/Quarrel get deselected on every time I log in. A few of my other problem components are Heavy lasers on different ships and Targeting Telemetry.

I've also noticed that most of the time it only happens when I first log in for the day, however swapping servers multiple times in the same day sometimes triggers it again. So if I do a lot of hopping between say Satele Shan and Starforge in the same day, it sometimes triggers the deselect bug again.
DrakolichDrakolích
The BastionTwitch Stream

phalczen's Avatar


phalczen
11.19.2019 , 09:07 AM | #6
Quote: Originally Posted by Verain View Post
-The deselect never happens while you are logged in, only once you have logged out
I have never had the bug recur if I was just logged out to the character select screen and swapped characters, regardless of the length of play session, and of course that implies I didn't server hop either. I'd have to be logged out for a while, at the SERVER select screen, for it to recur. Drak is obviously reporting it occurring sometimes with server swapping, but it raises the question if anyone has ever had the bug if you just change characters?

I find the bug disproportionately affects primaries. I can't say I've seen it affect any component other than primaries for any of my toons in probably years. That's not to say I believe the bug to be exclusive to primaries, obviously it isn't for some people, but it has been for me, for years.

I also find the bug disproportionately affects newer toons. Its happened rarely on my oldest, if ever, toon, Pyro, as best I can recall, who dates back to day 1.

I can confirm Verain's observations that the bug can sometimes go away, for a time, by moving slots. However, that is not a consistent workaround. It is the best workaround though. I find it affects ships less often if I order the ships as, from left to right, T2Strike, T1Strike, T1B, T3G, T3Scout. I find if the strikes are ok and the others are not I can sometimes free myself of the bug temporarily by exchanging the last 3 slots. That method used to work better before 6.0, I find it less effective after 6.0. Clearly some of the code was touched for 6.0, even if briefly, since: cxp was changed to renown; the typos on the T3B were corrected; the display of crew passives were broken; and for "battle over iokath" was made /who searchable.

Being a two-computer user, I can say the bug occurs in ships regardless of the computer I am on. A character can be ok on my laptop at work and bugged when I get home. That implies, to me, that at least some of the bug originates server side.
If you think I've made a good contribution with this post, I kindly ask that you use my Refer a Friend link! Here is more information about the program.

Linuxizer's Avatar


Linuxizer
11.25.2019 , 07:54 PM | #7
If the tier 4 upgrade is fine, then there is no need to scroll down to check the tier 5, for those components where you need to scroll down to see the tier 5. If the tier 5 upgrade got deselected, then the tier 4 is deselected too.

The reverse is not true though. I've seen the BLC tier 4 deselected while the tier 5 was still fine. This may be only on ships I hadn't flown since before V5.5, when the BLC tier 3 and 4 upgrades were moved around,

Quote: Originally Posted by phalczen View Post

I find the bug disproportionately affects primaries. I can't say I've seen it affect any component other than primaries for any of my toons in probably years. That's not to say I believe the bug to be exclusive to primaries, obviously it isn't for some people, but it has been for me, for years.
I guess it varies from user to user. I see it on one a railgun pretty often.
Starfighter videos on youtube


Referral link: https://www.swtor.com/r/jBHrWL

DakhathKilrathi's Avatar


DakhathKilrathi
11.26.2019 , 01:30 AM | #8
I had it on Targeting Telemetry on my Flashfire just today.

Stradlin's Avatar


Stradlin
12.01.2019 , 05:20 AM | #9
Certain components and/or certain ships seem protected from this, far as I can tell. I've never had this happen on any components I use in a T3 Strike for example. Despite rolling with proton torpedos, which regularly lose their last two tiers on all other ships I fly.
:

cheese_cake's Avatar


cheese_cake
12.01.2019 , 10:28 PM | #10
Interesting. It never happens with Proton Torpedoes for me. It's always the primary weapon of the ships in my first & last slot.