Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Put in Queue When Trying to Log on After 5.10.3

STAR WARS: The Old Republic > English > General Discussion
Put in Queue When Trying to Log on After 5.10.3

Nmyownworld's Avatar


Nmyownworld
06.04.2019 , 10:11 AM | #1
I'm in NA, and last logged on to the Star Forge server before the 5.10.3 patch. I downloaded the patch after SWTOR posted that the servers were back up. I didn't have time to get in the game until now after the patch. When I just logged on, I was taken to the server selection screen, with a message that I'm number 192 in a queue to log on to a server.

melodylane's Avatar


melodylane
06.04.2019 , 10:20 AM | #2
We are having the same issue. Glad to see we are not the only ones. Has there been any change in your situation? Im on starforge


"For some people this world ain't never gonna be right.... Maybe your Mattie's one of those people" ~ Doc Holiday -Tombstone-

Nmyownworld's Avatar


Nmyownworld
06.04.2019 , 10:24 AM | #3
No change, although there are others who are being put in to a queue for the Star Forge server in this thread.

TrixxieTriss's Avatar


TrixxieTriss
06.04.2019 , 10:24 AM | #4
Same here. I just got onto the server after 5 min wait. Clicked my character and it’s just spinning the wheel on the loading screen while I’ve been sitting here for the last min or so.

There is something seriously wrong with the servers.

Evensong's Avatar


Evensong
06.04.2019 , 10:26 AM | #5
Same here, also when you get in loading takes forever
Deep in the human unconscious is a pervasive need for a logical universe that makes sense. But the real universe is always one step beyond logic.