Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

June 2nd Patch - Stops server from loading

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
June 2nd Patch - Stops server from loading

JediSkyfall's Avatar


JediSkyfall
05.29.2020 , 08:01 PM | #1
The patch 6.1.1b that is slated for June 2nd release, is making it impossible to enter the game now. Please advise.

Sincerely,
Richard M.

Oeconomicus's Avatar


Oeconomicus
05.30.2020 , 11:20 AM | #2
Why do you think that a patch that has not been deployed yet is responsible for Connection issues?
I am playing on Tulak Hord and everything works fine!
Duct tape is like the force. It has a light side, and a dark side, and it holds the universe together.

Ravshar's Avatar


Ravshar
05.31.2020 , 10:00 AM | #3
Quote: Originally Posted by Oeconomicus View Post
Why do you think that a patch that has not been deployed yet is responsible for Connection issues?
Because that is what it looks like if you don't know any better. Game says installing 100% updating complete... never actually loads. Patch notes link next to the unclickable play button is for the update version number that is not due till the 2nd.

I've not played or updated the game in a long time myself, so I'll probably just uninstall/reinstall everything and go from there. Do wish I had made sure it was working before I restarted my sub. Oh well.

ceryxp's Avatar


ceryxp
05.31.2020 , 10:20 AM | #4
Quote: Originally Posted by Ravshar View Post
Because that is what it looks like if you don't know any better. Game says installing 100% updating complete... never actually loads. Patch notes link next to the unclickable play button is for the update version number that is not due till the 2nd.

I've not played or updated the game in a long time myself, so I'll probably just uninstall/reinstall everything and go from there. Do wish I had made sure it was working before I restarted my sub. Oh well.
What you are describing is a common issue with the BitRaider streaming client. There are a few things you can do that will usually resolve the issue.

Start with the easy step. Reboot your computer, router and/or modem. Often that will resolve issues with the streaming client.

Next has to do with the BitRaider Service. Occasionally something will prevent it from running. The following link has instructions on how to ensure the service is running and doesn't pause. Note that while the guide specifically mentions problems with AVG people have reported having problems with Avast AV, too. The problem can also occur with your firewall settings if you're using one.
https://answers.ea.com/t5/Troublesho...-p/5282877#M28

If that doesn't resolve the issue you can force a client repair. The following link has instructions for how to do that. The first set of instructions is for the BitRaider client.
https://answers.ea.com/t5/Troublesho...-p/6454174#M39

Lastly, if you want to remove BitRaider entirely, something I highly recommend as BitRaider has a lot of problems and can be very temperamental, especially if you have any sort of connection issue with the server (can be anywhere along the line, so not necessarily your connection or the game server). This link will instruct you on how to switch from the streaming client to the non-streaming client. The advantage of the streaming client is it allows you to create a character and play on the starter worlds while the game downloads in the background. If the game is already installed then that affords no benefit and the downsides of the BitRaider client don't, in my opinion, out weight the problems it has. If you decide to switch you will have to download the game again, but once it's done you can easily transfer the game from one computer to the next by using a large flash drive (need ~45 GB for base, double with PTS installed) or other external storage.
https://answers.ea.com/t5/Troublesho...-p/4867417#M27
--------------------------------------------------
Click the link. You know you wanna. You'll get free stuff. - http://www.swtor.com/r/W9ZqZj

Ravshar's Avatar


Ravshar
05.31.2020 , 10:37 AM | #5
Quote: Originally Posted by ceryxp View Post
What you are describing is a common issue with the BitRaider streaming client. There are a few things you can do that will usually resolve the issue.
Thank you. Once you mentioned bitraider it all sort of clicked. I remember having problems with it before. So I'm going with the last option, the one to remove bitraider. Sadly I had already uninstalled so it will probably take a while before its playable, but at least its updating now. Hopefully your info will help the original poster as well. Anyway, thanks again.