Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

[Bug] GSF is broken again: weapons are deselected on many ships.

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
[Bug] GSF is broken again: weapons are deselected on many ships.
First BioWare Post First BioWare Post

DakhathKilrathi's Avatar


DakhathKilrathi
08.18.2015 , 04:33 PM | #1
As of the patch this week, primary and secondary weapons (and in some cases systems components) are deselected on many ships, and it is possible to go into a match that way. With no weapons.

That is, no ability to play the game.

This is a big deal. Because this shows up again even after you reselect your weapons/components, this is game-breaking. Players should not have to check all of their loadouts every time they log in. A fix would be nice, but if you can't do that, at least make it so that you can't queue for a match with no weapons selected. The new player experience is bad enough as it is without this mess.

I don't know what the pattern is. It affects some ships, but not all, and it's not consistent across my alts.

On my Pub side alt, all but one of my ships (all mastered) were affected. It looks like this when you see it. http://i.imgur.com/DjTxIk9.png

Other players have also described the same problem:

Quote: Originally Posted by Nemarus View Post
Hangar view: http://i.imgur.com/XjNrXdO.jpg

I decided to take it for a spin...

http://i.imgur.com/GiSC9X6.jpg

I was less than optimally effective...

http://i.imgur.com/tAjE3V3.jpg

I was able to fix this back in the Hangar by simply selecting a weapon. But it certainly is strange.

Unfortunately, there didn't seem to be any pattern. My Sting and Jurgoran were missing their BLC's, but my Mangler had its equipped. I had two Cartel ships missing HLC's, but my Razorwire had its fine.

Still... DID THEY CHANGE SOMETHING IN THE MATRIX?!
Some are reporting that it happens every time they log in. If that's the case, even just for some people, it's more than a minor inconvenience.

Edit: confirmed that this has a chance to happen more than once on the same toon and on more than just weapons. See http://www.swtor.com/community/showt...01#post8392301 for more information.

All Major Components are affected.

caederon's Avatar


caederon
08.18.2015 , 09:48 PM | #2
This affected me as well, on both servers I played on tonight. Players in matches were confusedly asking why they had no weapons and could not target people. The problem seemed random as to what ships it affected, and was in all cases that I encountered limited to primary weapons. Everyone I talked to had experienced the bug.

This is ridiculous.

New people trying GSF for the first time may end up with no weapons, no idea why they have no weapons, and no reason to bother figuring it out. Hotfix it, do not wait until the next patch.

Despon

Nemarus's Avatar


Nemarus
08.18.2015 , 11:24 PM | #3
It appears random each time you log in.

Earlier today I logged in and my Sting was only missing its primary weapon. I fixed it. Later on I logged in again and my Sting (same character) was now missing its System component.

It's something that happens on character login, when GSF data is first loaded.
Shayd / Callem / RK-4X / "Trynt" - Leader of <Eclipse Squadron>, The Ebon Hawk
http://EclipseSquadron.enjin.com Imperial GSF-focused guild

"Serve the Emperor above all others."

ptwonline's Avatar


ptwonline
08.18.2015 , 11:42 PM | #4
Observations:
It doesn't happen to every ship. Usually 4 out of the 5 available, I notice.

First Login: 1st component de-selected (blasters).
Second Login: 2nd component de-selected.
Third Login: 3 ships had 3rd component de-selected, 1 had the second component de-selected.

Lavaar's Avatar


Lavaar
08.19.2015 , 12:18 AM | #5
This has the potential to heavily discourage players that attempt to play GSF and are unable to fire during a match. I stumbled upon this bug earlier today, and to someone who is unable to discern that this is indeed a bug, it could leave a very very bad taste in their mouth.

MiaowZedong's Avatar


MiaowZedong
08.19.2015 , 02:01 AM | #6
This is the kind of stuff that needs to be fixed yesterday.

OKonst's Avatar


OKonst
08.19.2015 , 05:24 AM | #7
Can confirm that it's happening here as well, including the random component AND the problem showing up AGAIN after re-starting SWTOR.

The only thing we can do at the moment is copy-pasting a reminder in GSF-Chat before/after every game so that people may even fix their loadouts before going into their next match - but this does NOTHING for new players who are not in the GSF-Channel!

This has to be fixed ASAP!
Ronik T3-M4
Vivios T3-M4

DakhathKilrathi's Avatar


DakhathKilrathi
08.19.2015 , 08:03 AM | #8
I still can't see any sure pattern to this. Some alts are affected, some aren't. It's not always the same component. What I do know is that this bug has the potential to kill what remains of the GSF community.

Please, at least acknowledge this. This can't be left this way for very long if you want the people who enjoy this part of the game to stick around.

nyghtrunner's Avatar


nyghtrunner
08.19.2015 , 09:53 AM | #9
Ran into the same problem across 2 servers last night, and couldn't figure out a rhyme or reason. I've seen Primaries, Secondaries, and Systems affected so far. The Systems was even on a stock ship, with an alt that only has half a dozen games or so, so it doesn't seem to be something to do with maxed ships, which was kind of my initial hope.

There really seems to be no pattern, and even fixing things doesn't guarantee they stay that way. As Nemarus said earlier, there seems to be a chance it will happen to some number of ships each time you log in.

I don't want to whine or anything, but it definitely makes me think that there wasn't really any GSF testing prior to the 3.3.1 patch... I could see missing a spot check, I guess, but I can't believe a match was tried. And where it happens to weapons, they're just missing from the model in the hangar, so it's pretty easy to see which ships it has happened to right away.

Were I to hazard a guess, it's some kind of order of operations issue, where it expects values that aren't set when the hangar is instantiated.
Master, I marked the best escape pod for your use. I of course, will go down with the ship.
Graendahl / Semírhage : Hawkë / Mierín

JediBoadicea's Avatar


JediBoadicea
08.19.2015 , 01:39 PM | #10
Just adding another post to keep this bumped up. Like others, I can confirm this is still happening today, with new "deselected" components randomized upon each login.