Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Declaration Of War Bugged

PadawanLayback's Avatar

02.24.2018 , 02:17 PM | #51
I was having the same problem tried everything but reinstalling and 2nd computer I was pissed that what fixed was pressing The ESC key to exit the convo then talk again and it was like it never happened ***(p.s. thanks to who said that worked)

ViralSilver's Avatar

07.31.2018 , 01:15 PM | #52
It's really annoying to think that this bug has been in the game for 6 years almost. But after a load of kerfuffle, it seemed that lowering the graphics quality at every setting, travelling to Belsavis and pressing ESC to moved out of the conversation twice let me start the conversation and progress past the Vette dialogue choice.

Hope it helps

Higgyguy's Avatar

01.08.2019 , 05:08 AM | #53
Quote: Originally Posted by TheAceofSpade View Post
i am also having this issue, have reset the quest twice, have completely closed TOR and reopened and still no dice. can't continue the warrior storyline from this point
if you're having the servant one bug what worked for me was go to belsavis lower graphics to lowest settings then go quesh then belsavis