Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

[BUG] Starship Power Conversion Module (not GSF) Broken

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
[BUG] Starship Power Conversion Module (not GSF) Broken
First BioWare Post First BioWare Post

Nvara's Avatar


Nvara
11.12.2015 , 04:30 PM | #61
My Sorcerer, Shadow and Operative all have this bug. My Powertech who also bought an IMP a few nights ago, does not. Trying to figure out how hers got "stuck on" and the others didn't... Ive tried logging in and out on fleet, planets, ship, and stronghold and with/without companions active after equipping it and cant get it to stick. She is also my cybertech, makes other ship parts but not these...

Anyone else have some toons bugged and others not? Maybe together we can find a workaround.

Can't believe this was reported 3+ weeks ago and its still not fixed.

Kaerta's Avatar


Kaerta
11.14.2015 , 07:50 AM | #62
Same issue here on my Sage. It's my only character with ship equipment, so can't test on others.

dave_the_nerd's Avatar


dave_the_nerd
11.15.2015 , 12:08 AM | #63
Also having this problem. (+1, upvote, whatever.)

Hrimrisar's Avatar


Hrimrisar
11.15.2015 , 02:39 AM | #64
Same problem. Just bought the item, found out it didn't work, can't refund. Please fix.

Chiyeko's Avatar


Chiyeko
11.16.2015 , 04:53 PM | #65
Same bug here, really quite annoying to spend 200k on something which does not work.
Inter arma enim silent leges.

_Satyre_'s Avatar


_Satyre_
11.17.2015 , 05:06 AM | #66
Same bug here as well.

Sold the module and purchased a new one. Same bug again.

ShepardSpock's Avatar


ShepardSpock
11.19.2015 , 09:41 PM | #67
One good thing about the latest patch was this seems to be fixed.

PatT's Avatar


PatT
11.20.2015 , 12:34 PM | #68
Quote: Originally Posted by bantharodeo View Post
Having this issue as well. Module will equip but seem to get bumped back into inventory whenever I zone, including at start of space mission. Doesn't seem to be happening on all characters.
it's happening to all of mine
Simple happy language words!