Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

The little lock on left of the hot key bar

STAR WARS: The Old Republic > English > General Discussion
The little lock on left of the hot key bar

Superpasta's Avatar

09.21.2012 , 08:44 AM | #21
Then try to get a programmable mouse, that will improve your game play experience a lot more.

By all mean, mouse clicker doesn't mean you have no skill, it actually means you are giving yourselves a more difficult time to play comparing with the people taking in hardware advantage, it costs you more skill to play in order to achieve the same. A smart mouse or keyboard doesn't make you epic, but it is a quality of life improvement.

If you can manage playing with hot-bar clicking, I see no reason where you would not enjoy changing your mouse habit.

Rafaman's Avatar

09.21.2012 , 08:54 AM | #22
I am not a "clicker" and I have run into this problem. It's simple. I lose track of my mouse cursor since essentially I don't use it to click on anything. However, I do use the mouse buttons to turn and what not, and when I do, if the cursor is over a quickbar, it moves the ability right off the bar causing huge problems especially with my Naga mappings.

Now, having said that... this is totally my fault. I forget to lock the quickbars after making a change or moving things around. I have never accidentally unlocked the bars during a fight. The lock is small and requires a precision click, so that is not the issue. That said, I like the locking mechanism as it stands.

GnatB's Avatar

09.21.2012 , 10:34 AM | #23
Quote: Originally Posted by Lionflash View Post
Am I the only one who can't be bothered to hotkey...

- those 60 minute buffs
- saber forms / gas cylinders / etc...
- heroic moments
- emergency fleet pass + quick travel
- my DD Flaregun I use when I score in huttball

I never need to use them in emergency situation and I can be bothered to bind them, I'll forget them anyway.

I keep that lock locked at all times and have yet to accidentally unlock it though...
Nope. But I have all those abilities in the leftside bar nowhere near the unlock button.

'Course, since I keybind everything, I don't ever actually bother locking the buttons, Only time I'm clicking there is when I WANT to move stuff around.

pooks's Avatar

09.21.2012 , 11:31 AM | #24
Quote: Originally Posted by DevReverRat View Post
I am a disable veteran and that is the way I play..Why can't they just put it at the top of the screen in that bar .
This. My abilities get moved off the hotbars during a fight very often. I tried placing the Malgus plama bomb thing icon in the 1st box but that hasn't helped; the abilities still get removed and lost.

The little lock isn't a lock. Woud be nice to have it perma locked in preferences.
1 Free Character Transfer + other Goodies - Just use my Official SWTOR Refer a Friend Code:

BeToo's Avatar

09.21.2012 , 11:39 AM | #25
I wish they would move that little lock at the left of the hot key bar to the top bar..
I have the same problem. Best 'fix' I've thought of is with the UI editor now you can change the original main bar to become one of the secondary bars so the 'lock button' is no longer on the 'new' main bar.

Trews's Avatar

09.21.2012 , 11:57 AM | #26
Quote: Originally Posted by DevReverRat View Post
Hey everyone
I wish they would move that little lock at the left of the hot key bar to the top bar..
So when I am in combat and using my mouse I don't move my hot keys around or lose some!

you actually got a suprising number of bites,
well done sir/madam

HelinCarnate's Avatar

09.21.2012 , 12:07 PM | #27
I have 3 bars at the bottom and 1 bar off to the right filled with stuff I hardly ever use. You could change your layout to be similar and have box 1 off to the right going vertical, thereby decreasing the odds that you could click on it in error.

Is a much better solution IMHO however.
Dear BW,
Please nerf paper and buff rock. Scissors is fine as is.
Signed, Rock. obligatory referral link.

manchusabre's Avatar

09.21.2012 , 12:35 PM | #28
Would be nice to fix that. I have the same issues when I accidentally click the silly lock.

Joesixxpack's Avatar

09.21.2012 , 12:57 PM | #29
Lrn2 keybind is a dumb answer to the OP. Everyone has their own preferences.

That button should be a UI option to put it there or not.

If you do want to go the ton o' buttons mouse route, Logitech G600 is pretty good, I haven't had any problems with it.

Edit: Nevermind, took G600 back, memory and another bug. Shame since otherwise it kicks A.

MadMacRiverRat's Avatar

11.08.2012 , 08:57 AM | #30
I think the lock should be moved to the top of the screen on that toolbar .
Thanks for bring that up.