Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Khem Val gets in the way.

STAR WARS: The Old Republic > English > Classes
Khem Val gets in the way.

eisra's Avatar


eisra
01.08.2012 , 10:22 PM | #1
I am finding Khem Val very irritating as a companion for a few reasons.

The most annoying aspect of Khem Val is that his target box is too huge. It means that every time I run towards a quest giver or any interactable object, Khem's target box gets in the way, and he starts talking as if I wanted to have a conversation with him. Of course, every time I accidentally click on him, he goes on in his alien language.

The more minor problem is that when I am running around, a third of the time, my whole screen fills up with Khem's back, sometimes his buttocks when I am moving downwards. It is minor issue but has a definite effect on my enjoyment of the game.

Of course, there are some solutions I can take myself. Constantly changing camera angles so Khem does not cover the targets in the middle of the screen, or wait till level 25 and get some other companions. I am quite sure that the developers have not intended for him to be such an irritation.

Suggestions:
1) Position Khem (or for that matter, any other companion) away from the direct back of the character. Put them a little further to the sides.
2) Reduce the size of Khem. I can see how this would break the RP immersion, though.
3) Reduce the target box of Khem to be the same as smaller companions like Mako, so even if his body is blocking an interactable object, I will still be able to click on it. It takes away the small benefit of easily targeting Khem with a mouse in a fight, but who targets the toon anyway.

Jaikob's Avatar


Jaikob
01.08.2012 , 10:46 PM | #2
I agree with you and suffer the same problem as well.

livnthedream's Avatar


livnthedream
01.08.2012 , 10:47 PM | #3
zoom your camera out further and its not an issue.

Sereloth's Avatar


Sereloth
01.08.2012 , 11:35 PM | #4
I had this problem until I zoomed my camera out.

eisra's Avatar


eisra
01.08.2012 , 11:46 PM | #5
I have my camera zoomed all the way out. It means that Khem Val does not fill the screen as much, but it still does not solve the problem of him getting in the way of interactable objects in front of my character.

I noticed that Khem Val has a really large target box that extends a good 1 in-game foot around his actual body. That gets in the way of conversations and clicking on stuff. His target box should be smaller than his body, not twice the size of his already huge body.

rfcsoulja's Avatar


rfcsoulja
01.09.2012 , 12:17 AM | #6
Did you go to preferences and set your max zoom out farther away? This isn't an issue at all with me.

eisra's Avatar


eisra
01.09.2012 , 12:36 AM | #7
Quote: Originally Posted by rfcsoulja View Post
Did you go to preferences and set your max zoom out farther away? This isn't an issue at all with me.
Yes, I did. I suppose that's the best solution for the moment. 75%+ and tilting the camera upwards make me feel like I am playing an RTS though.

SithVenom's Avatar


SithVenom
01.09.2012 , 01:11 AM | #8
I used the zoom out method too, but i got used to swinging the camera around too in beta. I got so used to the option reseting so much, that I just swing the camera around any time i need to pick up x or talk to y. Try that as another option. Eventually you won't even realize that you are doing it. Even when I am zoomed out a bit I still do it.

Humus_'s Avatar


Humus_
01.09.2012 , 03:55 AM | #9
Agreed.

Also, please learn him NOT to stand on tables etc. Very, and I do mean VERY often Khem's huge hitbox blocks an object or the quest giver.. so I reposition myself to give a clear line of click, just to have my frigging companion reposition himself as well to be BACK in front of the quest thing !!!

Very often he will even stand on tables etc to do this (this happens so often that it is really REALLY annoying)

I really like him and all, but the constant alien language and quest blocking means that I now only use him on elite fights.

Udolpho's Avatar


Udolpho
01.09.2012 , 05:45 AM | #10
Bad Khem! Down! No. Not allowed on the tables. --I'm sorry sir, I'm still house training him, he lived in a cave for most of his life, he doesn't know any better.
Pink is the new evil.
Wear it or die.