Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Canadian Friend can't connect to SWTOR servers since maintenance on 02/13/19

STAR WARS: The Old Republic > English > General Discussion
Canadian Friend can't connect to SWTOR servers since maintenance on 02/13/19

Jacianna's Avatar


Jacianna
02.14.2019 , 02:50 AM | #1
Just out of curiosity, are there any Canadians here who have been having a hard time logging into the servers once you start up the game?

I have a friend in Canada who was trying to get on earlier and it would take her to the server list then say she couldn't connect. She tried this quite a few times even after restarting her computer and doing the drastic uninstall and reinstall and she's still not having any luck. I just want to know if this was an isolated case for her or if it's happening to anyone else since this maintenance update, cause I live in the U.S. and I was able to get onto SWTOR just fine

And before anyone asks, she did try making sure it wasn't blocked by her firewall or her antivirus. She's tried running it as admin. Still nothing. She's so frustrated she's given up for the night on trying to deal with it, but I just wanted to see if maybe it was an isolated incident or not

MadDutchman's Avatar


MadDutchman
02.14.2019 , 07:36 PM | #2
No problem here.

Location: Edmonton, Alberta
ISP: Shaw

Also, might want to repost this in General Discussion. This forum is for discussion of the wider Star Wars universe and not SWTOR itself. As such it has much lower traffic. If you do, include her region and ISP if you can, we might be able to provide more specific help.
Demand: Are. We. There. Yet.

Use my referral link for free goodies.

Freshiefromafar's Avatar


Freshiefromafar
02.14.2019 , 08:55 PM | #3
Uninstall and reinstall, same problem happened to me.