Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Can't click Play on launcher

slaveteri's Avatar


slaveteri
01.29.2020 , 11:47 PM | #1
Trying to load SWTOR tonight and play, like i do every night. Log in, put in my security key, then i get to the screen where it checks for patches. It sits there "initializing" forever, then pops up the error "This application has encountered an unspecified error. Please try this patch again." I've done this several times. i've also tried to run the verification you can select in settings to check the files, but that isn't an option (is grayed out.) How do i fix this?

Thank you.

(ETA: Wow, it's been forever since i posted. The server in my signature hasn't existed for years.)
teri | xiombarg
Recruitment Officer
Pak'Cafan - US Juyo

Athuswarrior's Avatar


Athuswarrior
02.07.2020 , 05:39 AM | #2
hi im having the same problem it doesnt pass from verifying 0% but doesnt give any error, i wonder if the problem is from windows 10 because i tried on my oder computer with a older windows version and it worked, wonder if someone can help.

JediQuaker's Avatar


JediQuaker
02.10.2020 , 09:38 AM | #3
The problem is often related to Windows updates combined with outdated drivers. Sometimes, simply rebooting the computer will fix it. Sometimes you need to update your drivers - all drivers, not just graphics.
Hold water, a sieve may not, but hold another sieve, it will - Yoda..

Referral code - http://www.swtor.com/r/dZ8wSV