Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Unable to load PTS

Meshla_Naast's Avatar

03.20.2020 , 08:26 PM | #1
I have tried to load the PTS several times today, and during other test cycles on the PTS, the last cycle, and this one, I haven't been able to load it at all. It gets stuck loading Main Assets 340, and does not progress. It also locks up my launcher so I have to close it via task manager. Launcher repair has done nothing to fix this issue.

Image at the below link:
Callysta Gseran [Caitryia]
Lvl 75 Sage | Sorc
Guild: <Hellbent> | <Your Compaion>
Server: Star Forge

DarkLordSnake's Avatar

05.24.2020 , 07:28 PM | #2
Sadly it seems the devs do not even care to fix it, I've sent in multiple DM's to staff members and submitted a ticket about the whole situation.
It's more hilarious when I got the response back from a customer support member claiming the PTS servers are offline when they're still active.
They won't fix it.
For New Fresh characters, be sure to follow the link below for some awesome goodies!

Pallais's Avatar

09.22.2020 , 02:24 PM | #3
I'm having the same issue under Steam with installing Main Assets 360 for PTS 6.1.4. The launcher is sitting at 0%.

Edit: It doesn't matter if I run the launcher in Administrator mode or not. I get the same (hung) result both ways.
Pallais on Star Wars: Beyond the Stars, a SWTOR podcast.

Star Forge
Pallais, Concentration Sentinel <Impact>