Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Fate of the Jedi, class quest help

STAR WARS: The Old Republic > English > Classes
Fate of the Jedi, class quest help

Mindless_Freak's Avatar

12.29.2011 , 09:22 AM | #11
Quote: Originally Posted by Myranon View Post
Had the same problem just yet. Solved it as follows:

- Resetted the quest
- killed everyone
- tried to access bridge via locked door
- deactivated ALPHA first, then BETA, then GAMMA (obvious path would be heading for the two on the west side first)
- killed Angral & Kira
- escaped the fastest way possible
- entered my ship, used the holoterminal, headed for tython and... voilá
- questtracker didn't send me out of the Jedi-Temple, but straightforward to Jedi-council chambers
Tried that and nothing still stuck repeating it

MattWDavies's Avatar

12.30.2011 , 07:16 AM | #12
I'm stuck at it too, VERY annoying =/, call me stupid but how do u reset a class quest anyway? similar to someone else who posted this my quest tells me to go outside the jedi temple then vanihses, when i go to the council it says their not in session. blah

Mindless_Freak's Avatar

12.30.2011 , 09:37 AM | #13
I called Bioware yesterday and told them the issue, they said they are aware of it and trying to fix it, but gave no time frame on when it will get fixed, so hopefully the next patch out will fix it or even sooner this kind of sucks, Im stuck not playing till they can fix it. I dont feel like starting a new toon either

haydeelk's Avatar

12.30.2011 , 02:16 PM | #14
I am stuck at council too-

Kojimo's Avatar

01.01.2012 , 12:40 AM | #15
So yeah, turned 50, went to Ilum and there are no quests there! My class quest that has been bugged since lvl 32 must open up the dailies for that place.


Kauchman's Avatar

01.02.2012 , 01:31 PM | #16
I can confirm that solution to this "bug" is to talk to your holocomunicator on the ship BEFORE leaving to Tython. Once you left without talking to holocomunicator you are screwed ('cause you cant go back to The Oppressor) and you need to reset quest and do it all over again
Good Luck

troppersir's Avatar

01.02.2012 , 01:38 PM | #17
i cant even beeat darth angral im lvl 32 sentinel have tried 10 times now and he uses the same atack on me every time 1900 damge each

RDrury's Avatar

01.03.2012 , 05:01 AM | #18
Yeah i got the same thing too. I reset it twice did it twice on my own and once with a group, i can't hand it in at the holo terminal. but i also have the sand demon's lair quest too because i have the same bug with that, so i have two quests to hand in at the holo terminal.

Not good. Guess i'll just go balmorra and level to 50 :/ i am disappoint, especially after the 6 tickets i posted for each quest which just got closed on me.

Skatehead's Avatar

01.08.2012 , 12:17 AM | #19
I'm having a problem too. I get to the Jedi Council doors, right-click on it, and the chat bubble pops up. Normal.

I wait for like... 10 minutes. Nothing.

I have a better then decent connection, good computer, and I KNOW it shouldn't take this long. I'm just stuck waiting at this door hoping something will happen. Anyone know a fix or a workaround?

LordForgus's Avatar

01.08.2012 , 12:12 PM | #20
I'm having the same problem. I get to tython, map tells me to go outside, and the "council is not in session". I'm fine with repeating the quest if I have to, but I can't abandon it. This is ********. Anyone got a fix yet??