Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

bad fps despite good PC

BakuroX's Avatar


BakuroX
07.25.2019 , 10:22 AM | #1
I started playing the game a few months ago, I enjoy it a lot, but somehow it does not feel really smooth .
My Pc Specs:
i7-8700
Msi 1070 OC Armor 8gb
16gb Ram
144hz Monitor
650 w
It may not be on my PC, but maybe I have wrong settings in the game .
Thanks in advance

SteveTheCynic's Avatar


SteveTheCynic
07.25.2019 , 12:56 PM | #2
If the weather's like it is where I live, your PC's probably throttling because of the heat.

Sorry. It touched 42C = 104F today, which is way far above normal for the northern part of France.
http://www.swtor.com/r/Hg3sV2
To go to Belsavis, you must go to Belsavis.
> @"Biff.5312" said:
> Exercise your whimsy.

dvrocc's Avatar


dvrocc
08.17.2019 , 08:20 PM | #3
Any updates on the performance of Swtor on your PC? many reasons out there you are getting bad FPS, while in-game check the FPS and the COLOR of the FPS, the color of the FPS will help you pinpoint one of two hardware issues the CPU and GPU.

While in-game press "CTRL + SHIFT + F' keys and the FPS will be in the bottom-left of your screen, what color is the FPS? is it solid one color or bouncing between green and red?

Also cooling, can cause your PC to thermal throttle (slow down) so it wont breakdown on you and the real important part is that Swtor used to run horrible on a normal non SSD (hard drive) for years after it was released, a SSD drive is recommended to run Swtor from, I play my Swtor from a 240GB M.2 SSD and it is butter smooth!
MOBO: ASRock B450M-Pro4 AM4 | CPU: AMD Ryzen 5 2600 6c/12t | MEMORY: Corsair Vengeance LPX 16GB DDR4 2133 @3000mhz | GPU: XFX Radeon RX 590 Fatboy 8GB | PSU: EVGA G3 Supernova 650W | CASE: DIYPC Cuboid-G Red.