Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Graphic lag Issues

IllegalElite's Avatar


IllegalElite
10.31.2014 , 04:13 PM | #1
I've noticed a great deal of graphic lag lately and i blamed it on my graphics card, So i bought a new GTX 970, installed it and noticed a improvement But still in times of a bit of action i'm still experiencing graphic lag, Im running amd 3600mhz quads, 16gddr3 And 4gddr5 256bit width graphic card... What else could i be missing

StarSquirrel's Avatar


StarSquirrel
10.31.2014 , 10:34 PM | #2
If you're looking for a response from BW, your best bet would be here but be forewarned, I'm not sure how much help they'll be.

For help from other players, I'd recommend the above link or here or here.

I'm sorry I can't give you an answer, but I'm certain you'll have better luck if you repost in those sub forums.
I know if you look deep into your heart- which is currently all over that tree- you'll find a way to forgive me.

Aww, geez you look like a puppy! A blonde, eviscerated puppy!

-Alucard

IllegalElite's Avatar


IllegalElite
11.01.2014 , 09:24 AM | #3
Appreciate it, It came down to what I believe my sub par mother board bottle necking my performance, When i built it I was on a budget of about 500$, I know have another 1000$ worth of upgrade on the way to include a AMD FX 9590 H20 Cooled AM3+ 8C DT 220W, An asus Sabertooth 990fx motherboard and a SSD drive to run Operating system and swtor, If this does not fix my issue the parts can be scavenged by anyone who likes outside my condo window where it will fly though if I still experience lag