Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Khem Val Decoration missing

Salphidor's Avatar


Salphidor
05.16.2019 , 09:35 AM | #1
I tried to put Khem Val into my Stronghold, but when I put the decoration down (it is named Khem Val and shows Khem Val in the preview) it turns to Ak'ghal Usar. For story progress, I played the entire story including Ossus, didn't skip anything and of course chose Khem over Zash and got him back on Ossus. Also the decoration for Ak'ghal Usar is completely missing in the list, not that I actually need it Tried this with two Inquisitors, both have Khem back and both chose Ak'ghal Usar. Sadly don't have an Inquisitor who didn't choose Ak'ghal, so I can't check that.
There is no good and evil, there is only power and those too weak to seek it.

absolutetristan's Avatar


absolutetristan
05.16.2019 , 02:29 PM | #2
Yeah... ever since Ak'ghal was introduced, one dashade in the companion decorations listed as Khem, but when placed, he's Ak'ghal. It's been a while, and I think myself and others brought it up in an old decorations issue thread.

I like having my original five companions in my strongholds, so they're basically incomplete since I can't place down a Khem.
Refer a Friend Link: