Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Game won't launch

Rodaak's Avatar


Rodaak
05.15.2019 , 12:56 PM | #1
After todays patch my game won't launch. I get a message "This application has encountered and unspecific error. Please try this patch again."

nepochop's Avatar


nepochop
05.16.2019 , 02:03 AM | #2
What do you mean "game won't launch"? Does it mean the launcher, or when you click play on launcher?

SolReaper's Avatar


SolReaper
05.17.2019 , 07:58 PM | #3
I am having the same issue. Yesterday, 5/16/19, I was able to launch the game, login and play successfully. Now today, 5/17/19, I am getting an error when the streaming client starts initializing. It gives an error: "This application has encountered an unspecified error. Please try this patch again." The "Patch Notes" section says "Game Update 5.10.2a". I've tried uninstalling the game and the Bitraider client, reinstalling the launcher, repairing the launcher, adding Windows Firewall rules, checked my IP routing, etc. Nothing makes a difference.

Greywatcher's Avatar


Greywatcher
05.19.2019 , 11:46 AM | #4
I am getting the same issue - comes up with 'This application has encountered an unspecified error. Please try this patch again.' Yet my husband was able to patch and log in fine.
Moonstorm - Knight Commander of Corvus/Korvus
Check out our recruitment thread here

CorbanBritestar's Avatar


CorbanBritestar
05.20.2019 , 09:12 PM | #5
Quote: Originally Posted by Greywatcher View Post
I am getting the same issue - comes up with 'This application has encountered an unspecified error. Please try this patch again.'
Same issue the launcher says it's dl'n but it stays at 0% and task manager shows 0(zero) usage for SWTOR's "Launcher.exe"

Fixed the issue on my end my VP disabled the "BitRaider Mini-Support Service Stub Loader" It's located in the Task Manager under the Services Tab
RMB the mini-support
select "Properties"
on the Startup Type select "Automatic"
APPLY
OK