Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Many disconnects

Hitnmiss's Avatar


Hitnmiss
09.15.2019 , 07:22 PM | #1
Since the last backend update, I've had some disconnects. Today was pitiful. Hard to stay connected longer than 10 minutes.
First in Corellia, it was around every 5 minutes or so. Then I went to finish the class quest no disconnects. Go to Voss, there for not even 5 minutes disconnected.
Anyone else having a problem?

JediQuaker's Avatar


JediQuaker
09.16.2019 , 07:36 AM | #2
Nope.

It's probably a glitch somewhere between you and the servers. Or, a rare possibility that your computer's network hardware is glitchy due to damage caused by physical events or overheating. Or even just a bad cable.
Hold water, a sieve may not, but hold another sieve, it will - Yoda..

Referral code - http://www.swtor.com/r/dZ8wSV

fushnchips's Avatar


fushnchips
09.17.2019 , 12:39 AM | #3
Quote: Originally Posted by JediQuaker View Post
Nope.

It's probably a glitch somewhere between you and the servers. Or, a rare possibility that your computer's network hardware is glitchy due to damage caused by physical events or overheating. Or even just a bad cable.
Bioware run really crap servers
Pineapple on Pizza for life

Free stuff for you and me click here : Refer a Friend

OdinJediCovenant's Avatar


OdinJediCovenant
09.17.2019 , 01:32 AM | #4
Quote: Originally Posted by fushnchips View Post
Bioware run really crap servers
That may be true but he should still investigate the proplem first before just assuming its bioware's fault, for a start people say they have lag issues but ive never had any lag issues in the entire time ive played swtor.

Quote: Originally Posted by Hitnmiss View Post
Since the last backend update, I've had some disconnects. Today was pitiful. Hard to stay connected longer than 10 minutes.
First in Corellia, it was around every 5 minutes or so. Then I went to finish the class quest no disconnects. Go to Voss, there for not even 5 minutes disconnected.
Anyone else having a problem?
Use Ping plotter dude to see if theres any distruptions between your router to you then from you to the server and back again