Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

trooper mission glitch

kookiejosh's Avatar

01.23.2021 , 02:25 PM | #1
im on belsavis and am doing the mission change in plans where i have to talk to tobin. i talked to him and got the cutscene but after that it still says talk to tobin which does nothing. i tried resetting but that also wont work. what can work

Erevan_Kindelar's Avatar

01.23.2021 , 04:18 PM | #2
I cannot remember having any particular problems with that quest, but it has been a while since I put myself through the hassle of dealing with the Senate and being Garza's hunting hound.
It says to talk to Harlan Tobin, but is the quest marker on the map pointing to his current location? (I am thinking of the scenario where he might say "meet me at XYZ", and after the convo you can still see him in your current location, but yuo have to go to a different location and talk to him there. As I said, it has been a while...

Alternatively, either logging out and back in, or changing instances (open the map, and in the bottom right there is a selector so you can move to a different instance, if one has been created to manage the planetary population) can sometimes shake loose whatever cobwebs or bug carcasses have gotten into the system and are gunking things up.
I am telling the truth, honestly! I am as honest as the day is long! Besides, I am a terrible liar, everyone can see when I am lying - my lips are moving.
Like most other subs, I have a Referral Link. Clicking it gets you some stuff, and me some stuff too.

kookiejosh's Avatar

01.23.2021 , 09:30 PM | #3
i tried all of those things and he still sits there with the icon on the map but no icon above his head just telling me to go get em when i right click on him