Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Declaration Of War Bugged

xlordsithisx's Avatar

03.11.2012 , 04:08 PM | #1
Hi there everyone im a level 44 marauder.

Im on a mission that's called Declaration of war main storyline quest for the sith warrior.

(Spoiler Alert)


DonLocke's Avatar

03.12.2012 , 07:01 PM | #2
ummm put spoilers in your topic BRO
Run, Jump, Bleed(heal), Kill. Marauder Life.

TheAceofSpade's Avatar

04.11.2012 , 04:23 AM | #3
i am also having this issue, have reset the quest twice, have completely closed TOR and reopened and still no dice. can't continue the warrior storyline from this point
Cleansing the galaxy one Jedi at a time
Apply Now Nightmare Asylum

JinnyJinJin's Avatar

04.25.2012 , 06:57 PM | #4
I had the same issue. I used a different computer and tried it and it worked! try using a different pc.

schrismon's Avatar

04.30.2012 , 02:52 PM | #5
Same problem here. Have been going back and forth with customer service for over a week now. They don't seem to be making any progress. I don't have the option of using another computer, and shouldn't have to. Have reset and gone through the quest 4 times now trying different conversation option and different companions and still nothing. Anyone having any luck?

Yescek's Avatar

04.30.2012 , 05:36 PM | #6
I had this issue a long time ago. I also had my own little dance with Customer Service. It ended with a reinstall.

Hope you don't have to do that though............


06.17.2012 , 04:40 PM | #7
im having the same problem now and i tryed un installing and resetig quest and still nothing

heycallumj's Avatar

09.17.2012 , 06:44 AM | #8
Hi all
Just wondered if anyone had a way round this bug yet? I'm currently stuck in the same situation. I don't have the option of using a second computer and I really don't want to go down the reinstall route as I use a PAYG dongle for broadband.



MexMarine's Avatar

11.13.2012 , 01:12 AM | #9
Same situation exactly. No dialogue, Danced with customer service for 3 weeks now and to still to no avail. upset/sad/and mad. I reset the mission twice. get rid of my whole log, followed the customer services advice but had NO response after that. Downloaded all the updates to my drivers AND direct X to no avail Yet again. I had to start another character and works just fine. Please let me know whats up, if anything.

Lethadind's Avatar

01.18.2013 , 12:24 AM | #10
Uh. So. This is what I did, and for some reason it worked.

First off I was in windowed, non full-screen mode. I believe this is relatively important actually.

I tried a few times, didn't work, stared at the ugly guy doin his thang for like 10 minutes to no avail. Shut down my computer, it installed a random auto-update, booted it back up and tried again, still didn't work. Pissed, I found this forum, saw a bunch of people had the same issue and so I wrote them an in-game ticket.

Okay, here's the important part. Right after I wrote the ticket, I clicked on the holoterminal and alt-tabbed to my web-browser. You have to be in windowed mode to do this, or else the game freaks out. Not sure if "non full-screen" mode is important though.

I have no idea if I was just lucky, if it was the ticket that I put in, or if it was because I clicked out of the game and wasn't watching the TWO F***ING sentences this freak says for this dialogue (seriously, he says two things and it's over, after a few members of your crew pipe in a sentence or two), or a combination of all of these things. Anyway, try what I did in the order I did it, see if it helps.

The Order:

Click holoterminal - wait a while, it won't work. Restart your comp and the game. Click again, won't work again. Open up a ticket, submit ticket with a valid description. Click the holoterminal, click out of the game, and look at it in a minute or two.

Good luck.