Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Missile Lock woes: bugged or working as intended?

STAR WARS: The Old Republic > English > Galactic Starfighter
Missile Lock woes: bugged or working as intended?

PeterKannNix's Avatar


PeterKannNix
02.22.2014 , 10:27 AM | #11
Yeah i have that too..

sometimes it's the missile lock breaker of the target but most times it's lag.

I also have ships jumping through space quite often. Sometime to an degree that you can hit them with lasers...

Simple solution .. who has suck a crappy internet connect shouldn't be able to participate in GS. Nearly all other "fps" games kick player that can't fulfil some minimum ping rate and packet loss ratios.

Armonddd's Avatar


Armonddd
02.22.2014 , 12:11 PM | #12
Well, if you have a firing arc of 14 or so degrees, and the guy is 4 km away from you and moving relative up while you're moving relative down, and there's a half second of lag... even if you adjust "in time", the fact is that while the server is lagging, it considers both of you to be moving along the last known vectors of velocity. Half a second of moving at the wrong velocity is death for a missile lock. And the best part is, the lag can come from you, the server, or the other guy, so there's three places there for a ****up to occur.

This is just one more reason why clusters are the best lock-on weapons in the game.
Space Ace of <Death Squadron>, <Black Squadron>, <Eclipse Squadron>, and <solo da>

Jandi's Avatar


Jandi
02.22.2014 , 12:20 PM | #13
Yeah but I see it happen even when I'm chasing someone and both are going in the same direction. The lock just drops again and again.

BobBudJones's Avatar


BobBudJones
02.22.2014 , 12:32 PM | #14
To clarify for one responder, it is definitely not an activated defensive ability. You can see when those things happen and it's just not that. It also happens on all types of ships, even bombers who have no way of actively breaking lock.

As for lag, I agree with the guy who said "why is lock breaking when I can still hit with blasters?" That makes sense. Also, there are no other indicators of lag (i.e. jumping ships at these times). Furthermore, I just have to think that even if it IS caused by lag, if it's such a frequent problem for so many people, the mechanic simply needs to be changed somewhat if they can't do anything about the lag.

It's just too frustrating to repeatedly lose lock (for no good reason) and have to start over from scratch, when your windows of opportunity are generally so small, especially against good pilots. And of course it essentially nerfs any ships that use lock-on weapons.

Jandi's Avatar


Jandi
02.22.2014 , 12:37 PM | #15
Quote: Originally Posted by BobBudJones View Post
It's just too frustrating to repeatedly lose lock (for no good reason) and have to start over from scratch, when your windows of opportunity are generally so small, especially against good pilots. And of course it essentially nerfs any ships that use lock-on weapons.
I fly a Pike, it's not amusing at all since missiles are my main weapon. I can take out people with Quads as well, of course, but clusters are my main killing tool and losing locks for literally no apparent reason gets old.

Armonddd's Avatar


Armonddd
02.22.2014 , 12:43 PM | #16
Quote: Originally Posted by Jandi View Post
Yeah but I see it happen even when I'm chasing someone and both are going in the same direction. The lock just drops again and again.
If the two of you are relatively close, I can't explain that. If he's relatively near the edge of your lock range, though, even a fifth of a second of boost would take him out of range. Normally you'd be able to do something about it, but lag lol.
Space Ace of <Death Squadron>, <Black Squadron>, <Eclipse Squadron>, and <solo da>

Verain's Avatar


Verain
02.22.2014 , 03:43 PM | #17
There is NO way this is "server lag". I get this a lot, as I was piking it up today.

Typical:

Approach enemy, begin lock. Enemy begins boosting- lock lost but he never leaves circle. Begin second lock. Second lock goes live, enemy engines out of the missile midair. Right click right click right click right click (engine component is now over) right click -> begin third lock, immediate loss of lock within less than a second for no reason. Begin fourth lock, lock goes live, enemy takes missile.


UGHHHHHh

DroidDreamer's Avatar


DroidDreamer
02.22.2014 , 05:18 PM | #18
I used to buy the "edge of the firing arc" thing but too often locks break even with the target more or less dead center.
The DroidDreamer Legacy (Pot5 Server)
Eblen 50 Sorc heals | Sodan 50 Sniper | Trilliant 37 Immortal Jugg | Somnis 50 TankSin
They mark me with the lightning bolt in Huttball.

Jandi's Avatar


Jandi
02.22.2014 , 05:29 PM | #19
Quote: Originally Posted by Armonddd View Post
If the two of you are relatively close, I can't explain that. If he's relatively near the edge of your lock range, though, even a fifth of a second of boost would take him out of range. Normally you'd be able to do something about it, but lag lol.
Was just in a match and had trouble keeping a lock on a BOMBER! Was fine on other people, but not this guy, nope. That's ridiculous. I call shenanigans on this.

Xianyu's Avatar


Xianyu
02.22.2014 , 11:18 PM | #20
This happens to me every single gosh darn match.

I literally can't use proton torpedoes because of this. I can have a scout at 7-9000 metres, keep them dead centre of the firing circle, and get NOTHING.

The lock will drop half way through for no reason at all.

I followed a scout for a good twenty seconds while it was dogfighting. I lost lock at LEAST five or six times on the little ***** of a thing, without it leaving my range OR firing circle. And then there are times when I get a solid lock, release the button, and nothing happens.