Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Login Service Currently Unavailable

STAR WARS: The Old Republic > English > General Discussion
Login Service Currently Unavailable
First BioWare Post First BioWare Post

Kaeluwen's Avatar


Kaeluwen
11.22.2019 , 02:36 PM | #11
Eric,

Login is still not working. Giving out an unspecified error

xicana's Avatar


xicana
11.22.2019 , 03:08 PM | #12
I am currently getting the Unspecified Error as well. "The application has encountered an unspecified error. Please try this patch again.

UbberNub's Avatar


UbberNub
11.22.2019 , 03:58 PM | #13
I cant login and i says that my password / username / security key is wrong but i checked them all and they are all put in correctly, whats going on.

Aurkia's Avatar


Aurkia
11.22.2019 , 04:46 PM | #14
Im having this issue too. Just got home and its 545 EST.

DarkTergon's Avatar


DarkTergon
11.22.2019 , 06:05 PM | #15
Had the issue logging in, but when I shut the launcher down, and retried, it worked, also I noticed that when i tried logging in with all my details, user/pass/security, it'd hang for a while, but when i just put in the user/password, then logged in, then put in the security code on the next page, it logged in fine.
No Idea if people use these, but if so, here's my referral link
http://www.swtor.com/r/jFXFFQ

Percilator's Avatar


Percilator
11.22.2019 , 09:38 PM | #16
Satele Shan just lagged out hard for me, tried to log out when latency hit 45000ms and got stuck on a loading screen. Alt+F4 was my only choice.

Nebdar's Avatar


Nebdar
11.22.2019 , 09:57 PM | #17
I logged after a long while al is fine on Darth Malgus
Processing...

KBerling's Avatar


KBerling
11.23.2019 , 06:19 PM | #18
I am unable to log on about 20% of the time. This has been happening consistently for at least 3 months. The launcher initialization times out then I get this text next to a yellow pyramid caution icon:

"The application has encountered an unspecified error. Please try this patch again."

Then, about 25 seconds after closing the launcher, I get this on the desktop screen:

"Error
Unable to communicate with external UI. Exiting."

If I wait a few hours, I'm usually able to log on. Or sometimes I can logon if I restart my computer and try right away. But usually I just shut it all down in disgust and go do something else. Incredibly aggravating!

Gelious's Avatar


Gelious
11.23.2019 , 06:54 PM | #19
Quote: Originally Posted by KBerling View Post
I am unable to log on about 20% of the time. This has been happening consistently for at least 3 months. The launcher initialization times out then I get this text next to a yellow pyramid caution icon:

"The application has encountered an unspecified error. Please try this patch again."

Then, about 25 seconds after closing the launcher, I get this on the desktop screen:

"Error
Unable to communicate with external UI. Exiting."

If I wait a few hours, I'm usually able to log on. Or sometimes I can logon if I restart my computer and try right away. But usually I just shut it all down in disgust and go do something else. Incredibly aggravating!
This is a BitRaider error. Close all BitRaider processes, delete all XFR files and Config in Bitraider folder.

This will cause game to verify all its files, and allow you to play afterwards.

You may have to repeat the process each time you turn on your PC.
"They will not! I command them to know fear! To raise me to my throne! They can not!" - Soa. The Red Eclipse:
Gelious - Sith Marauder; Xatras - Jedi Guardian; Xatra - Commando; Helimana - Mercenary; Nellios - Operative; Mellas - Sith Assassin.

KBerling's Avatar


KBerling
11.23.2019 , 07:38 PM | #20
Thanks. I'll try that.