Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

"Andronikos Revel" Class Quest Bug

STAR WARS: The Old Republic > English > Classes
"Andronikos Revel" Class Quest Bug

Domitis's Avatar

01.14.2012 , 11:23 PM | #21
I had this problem, tried all the suggestions, except traveling to Belsavis, and nothing helped. Then i took all my armor off, and put it in my hold (for good measure). And sure enough, it worked fine when i tried it while naked. I suspect that my new mask, from Korriban, has something to do with it, as it is the only new piece that i had added since the last time i used the Holoterminal. Unfortunately, i can't test my theory, now. Maybe someone with this problem, can remove only thier mask.

PheonixRom's Avatar

01.21.2012 , 08:27 PM | #22
I noticed that this bug has been a major issue for many, including myself, and many, like me, have sent many tickets addressing the issue only to get generic or unhelpful solutions. I here to tell you that there is a solution, I have tested it my self and have had friends who also play Sith Inquisitors test it and have had positive results. The solution is simple yet complex for some. The reason these issues occur is that there is a binary error with the data that is being processed in the game. In simple words, its not the game that glitched or bug but your computer has an issue of processing the data in the game. For example, when doing the conversation part of "Andronikos Revel", your pc is trying to process to much data at one time, so it is unable to finish this process and leaves many people stuck in the conversation and unable to do anything except press the ESC button to reset the conversation. So here is the part that you are wanting to know, "how do I fix this Bug". the solutions, even though maybe hard for some people to do.

1.) Buy a newer computer with a better Data processor
2.) Try using a different computer to complete the quest.( this is what my friends and I did and is worked. Also you may want to reset the quest and start it from scratch when you do.)
3.) If the above solutions fail, it maybe a problem with your internet or internet provider. also if you are using a wireless connect, your device on your computer or router that sends/receives the data maybe broken.

Well hope this helps. It did for me and a good bit of my friends, Also I forgot to mention this also solves some of the glitches in the Bounty Hunter Class story line.

Pernai's Avatar

01.27.2012 , 11:46 AM | #23
Quote: Originally Posted by evileeyore View Post
2 possible solutions, only one of which worked for me:

Reset the Quest. I had to do this on the previous class quest's end and it only resets it to the last step, which for this one is "Go to your ship's docking bay"... it might work for you guys.
Resetting the quest the quest fixed it for me.