Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

"Andronikos Revel" Class Quest Bug

STAR WARS: The Old Republic > English > Classes
"Andronikos Revel" Class Quest Bug

Xanesst's Avatar

12.20.2011 , 10:32 AM | #1
Hey, i've been having trouble with this quest, and i just want to ask if anyone else has experienced a similar issue (and maybe how to fix it), or if i should contact the support.

Im currently at the stage where i have to use the Holoterminal on my ship. The thing is, when i do and the conversation ends, i get my characters face close-up and nothing happens (tried it like 10 times, with relogging, waiting for 15 mins+ etc....).

The quest doesnt continue, all i can do is press Escape, but that just resets the conversation and im stuck at "Use the Holoterminal on your ship" again. I cant proceed with the storyline.

If anyone had the same issue, i'd appreciate your help. If not i guess i have to contact the support :/.

Rhin's Avatar

12.20.2011 , 10:57 AM | #2
I have the same issue with using an intercom, just on a much later quest. It's a known issue, I'm afraid, across multiple classes. Since it's your class quest, though, there's not really a happy answer to this one. I think you just have to wait it out for a bioware fix.

Crushmode's Avatar

12.21.2011 , 03:33 PM | #3
I have the exact same issue, been trying all kinds of fixes. Hoping for the best and waiting on a ticket. Its incredibly frustrating and temporarily game breaking since its a class quest...

EchidnaKnuckles's Avatar

12.21.2011 , 09:51 PM | #4
I had the issue, figured out how to fix it myself. Get out of the ship at Tatooine, walk outside until you find a quest giver. Speak to him, let that conversation end, go back onto the ship and do the holoterminal again and you should find that it works.

Worked for me anyway

Cirosmar's Avatar

12.22.2011 , 12:04 AM | #5
I am having the same problem. I tried knuckles' suggestion and it did not work for me. I REALLY hope there's a solution/fix soon.

Knaffjibbawat's Avatar

12.22.2011 , 04:26 PM | #6
Try hitting ctrl-u twice. This will reload your UI, and quests and quests rewards are tied into that interface. Worked for me on several occasions.

Cirosmar's Avatar

12.22.2011 , 08:34 PM | #7
So, I finally got a reply to my ticket for this bug. They told me that they are unable to help and that i should just watch for a patch that will fix it...any other suggestions? The suggestions currently in this thread aren't working.

Ateg's Avatar

12.22.2011 , 10:22 PM | #8
Bump for possible response.

I am having the same issue.

This is a game breaking bug for an entire class and has been going on for two days at least and it's not fixed yet and no response?

That's unacceptable in my book.

Cirosmar's Avatar

12.23.2011 , 12:43 AM | #9
I agree...I'm basically unable to play my main if I don't want to redo areas...

impulsegod's Avatar

12.23.2011 , 01:45 AM | #10
Your class story shouldn't be slowed down at all by that quest. Unless you have done the quest on the next world, you have a place to go to continue your story. A minor hiccup of not being able to fully complete the class quest should be fixed later, but you still have class quests to do presumably.