Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

tatooine baloon ride

First BioWare Post First BioWare Post

Talimar's Avatar

07.16.2013 , 08:45 PM | #11
Wow. I remember when they tried to fix this bug, but it still drops out more often than not when you get close to the sandcrawler. Always has. The patch never fixed it fully.
"We're merging you with US servers. Your gameplay experience will be abysmal, but you'll have higher populations!"
"But we play at entirely different times."
"Doesn't matter. Our metrics will show higher populations."

Givemedanger's Avatar

07.21.2013 , 04:16 PM | #12
Baloon disappreared for me and some guy. It spawned far away. ***! You fixed nothing. T Y P I C A L.

Svarteryttaren's Avatar

07.23.2013 , 10:29 AM | #13
The baloon bug allways happens realy close to the destination (the crawler). But if you take the baloon two times in a row without zoning out of the tattoineinstance the baloon will never de-spawn the second time you ride it.

This is the only known fix that will for sertain take you to the datacron that I know of and it works for everyone that I have talked too. Since it is a long ride, the first time most people feels so angry that the dont try it twice in a row. Most people give up on this datacron.

A 2 min ride or someting would be enough, and a bug wouldnt feel so aggrivating if the ride was shorter.
BW: Plz add PvP that is storybaced so that it effects
the somehow or some objective based PvP > 8 vs 8

JediCounsular's Avatar

07.25.2013 , 07:29 PM | #14
Quote: Originally Posted by Exly View Post
A year and a half after launch and this is still broken. I find that fact both ridiculous and laughable.
Technically, this bug has been here ever since the game was released on first day of early access, but all the people that have been there since day 1 have known about the work-around to attain the 2 datacrons on the sandcrawler.

First, there appears to be 2 balloons, one that is bugged, and one that is NOT bugged, both moving in their elliptical orbit. The full round trip ride is 40 minutes, but to get from starting point to the sandcrawler should only be 20 minutes.

Second, while you are aboard the balloon...
* Dismiss your companion.
* Do NOT use any emotes.
* Do NOT craft anything.
* Move around a bit-do NOT allow yourself to go AFK.

If the balloon gets within sight of the sandcrawler and drops you to the ground. Don't get upset. It happens. We have all gone through this. The tricks to attaining the datacrons can be reached without using the balloon.

Tricks and how to get the datacrons (this can be through grouping with others or dueling).
* Duel: Have a knight or trooper use force push/concussion to blow you up to the top.
* If you are a knight and someone is up top, duel them and force jump to them.
* If you are a sage / vanguard and up on top, use rescue (force pull) / harpoon to pull others up to you.
These are only some examples, and both factions have used the same techniques to attain the datacrons.

Hope this helps, and may the force be with you.
The Ebon Hawk server, our roleplay home since March.22, 2011.

MocniSkopac's Avatar

07.26.2013 , 11:24 PM | #15
i can confirm that. when i was leveling my a sorc 6 months ago or so, i was waiting for the balloon with a irl friend, and when the balloon was near, it just *********** disappeared. irl friend saw the same thing and we were like what the ****. i know it was morning. this happened on tofn. i read all patch notes, and the balloon hasnt been in any of them since them, thus making it stll broken.

Undeadcenturion's Avatar

03.22.2014 , 07:50 PM | #16
Yeah, still on going. The baloon vanished right before I was supposed to hop on it. I had been waiting on hour for it to cycle through. While getting ganked multiple times by a 55 Pyro pos. Fck you and fck this game sometimes. Ive been complaining about this since launch. The excuses never end with this bug. Just admit it .. its beyond your brain power to fix. So its working as intended.
Rah-El Guardian Vadicus-El Jugg
Yorr-El Sentinel

Tessie's Avatar

09.01.2014 , 04:30 PM | #17
I had this problem once last week, and again today. I waited with two others for the balloon to arrive, and while it was about 1 or 2 minutes away, it despawned. There was no shadow visible. I waited around a while (not another full interval) but did not see the balloon again.