Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Game stopped launching

JakeMora's Avatar

11.17.2019 , 03:04 AM | #1
The launch window says "This application has encountered an unspecified error. Please try this patch again."
Current version 6.0.1

Last session my Jedi did get stuck in some terrain and I tried logging out and in to fix it before I thought of using the quick transport system, since logging in and out didn't work. But he relocated to a nearby fort and I logged back out.
Since then when I tried to start the game again a few hours later now I get the launch message and it won't launch.

Every happened before?

MK-ULTRA's Avatar

11.17.2019 , 03:57 AM | #2
Did you get it working?
You spelled tyranny wrong.

JakeMora's Avatar

11.18.2019 , 02:27 AM | #3
Next day and it launches okay. Might've been connection issue, server overload, or just temporary glitch after being stuck in terrain, no idea. Glad it fixed itself though, got me worried since I don't have an installation disk for this particular game, so a no fuss reinstall wasn't an option if it continued to error the launcher.