Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Download won't complete.

Dranid's Avatar


Dranid
02.21.2019 , 03:38 AM | #1
Decided to dive into swtor again, downloaded it, and can't access characters not on starting worlds. the launcher says the download is complete, but I can't use the repair too because it's apparently not complete(?). I had this issue the last time I played swtor a while ago, but it did eventually finish downloading. This time it isn't, I've left the launcheropn for hours at this point and nothing.

I've tried restarting the launcher, repairing the launcher, running the launcher in admin mode, and deleting the bitraider folder, all to no avail.

OwenBrooks's Avatar


OwenBrooks
02.21.2019 , 03:46 AM | #2
Repair is per https://answers.ea.com/t5/Troublesho...unread-message

Note: If using streaming (bitraider) launcher the repair function on the launcher used for non-streaming is disabled and will never enable to be run.

also wont hurt to check https://answers.ea.com/t5/Troublesho...unread-message

Dranid's Avatar


Dranid
02.21.2019 , 08:37 AM | #3
Tried both, it still won't work.