Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Mission broken? "Fate of the Jedi"

STAR WARS: The Old Republic > English > Classes
Mission broken? "Fate of the Jedi"

Teiki's Avatar


Teiki
01.24.2013 , 12:56 PM | #1
I was wondering if anyone else is having problems with the class Misison, "Fate of the Jedi?" I have defeated Darth Angral, helped Kira Carsen break free from the Emperor's hold, and escaped the Opperssor before it blew up. Everything worked fine up until that point.

It got weird after that. The mission log said to go use the Holo on my ship, so I ran aboard and clicked it. Nothing happened, nothing other than the quest updating to travel to Tython, which I did. When I got there It tells me to go outside of the Jedi Temple, which I do, but when I leave the Temple there is no place for me to go. I looked up a spoiler and it should tell me to go to the Jedi Counsel Chamber. When I try and enter the Chamber, it's a no go.

This seem to be a bug about a year ago, as i searched for it on the forums yesterday. I really didn't find any current answers to my problem. CS hasn't responded yet and was wondering if there was a work around .

Any help would be greatly appreciated

Thanks.

Teiki's Avatar


Teiki
01.24.2013 , 01:04 PM | #2
Okay found an old fix.

Traveling to Tatoonie seemed to update the mission.

I'm surprised and disappointed that this bug is not listed in the known issues.

Hopefully this can help anyone else stuck at this point.

Shadoweavez's Avatar


Shadoweavez
06.30.2014 , 01:43 PM | #3
I have the same issue. It is still broken.

So when it says "fly to Tython" and I go there NOTHING happens.

totally stuck, went to tatooine, didn't help.

I cannot advance past the 'Travel to Tython' part.