Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Unable to retrieve patch data...


Smokeing's Avatar

01.06.2012 , 08:54 AM | #51
I am on windows 7 and am fully up to date and i still cant get it.

Nthknight's Avatar

01.06.2012 , 08:55 AM | #52
My issue seemed to have fixed itself somehow, was trying for a good hour, left it for abit, then decided to patch up.

nadski's Avatar

02.05.2012 , 06:06 PM | #53
restarting the router and running the program as administrator worked for me


jimmynhk's Avatar

08.07.2013 , 07:59 AM | #54
i could not get anything to work then i went into program file ran fixlauncher fixed it right away after that it let me patch

tbonemc's Avatar

08.07.2013 , 08:49 AM | #55
Ive had this problem so many times its unreal. Have you tried using the launch start up repair it worked for me it should work for you with your problem with the patch. Hope this helps.

Argyawst lvl 50 Sith Assassin
Almuzuk lvl 50 Commando
Fiopea lvl 50 Sith Juggernaut
Larallalla lvl 50 Jedi Sage
Jechot lvl 50 Mercenary
Ninnich lvl 27 Scoundral