Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Horrid FPS


shinguvna's Avatar


shinguvna
12.29.2011 , 02:17 AM | #11
It's the optimization of CPU's that is the problem. The engine of this game doesn't support multicore by default so it's a bloody turtle. I overclocked my cpu a small amount and it reduced the stuttering in warzones slightly. Get on it Bioware, you obviously havn't done a good job inserting multicore support. I'd give those coders a good smack because every other issue is minor compared to this.

Nisuji's Avatar


Nisuji
12.29.2011 , 02:29 AM | #12
This FPS problem is getting frustrating... I would like to enjoy the game, I think it is a game that I can see myself playing for some time, however, due to the FPS problem that dream is becoming quickly diminished.

Here is what I got:

Graphic card used : Nvidia GeForce 335m
Driver version: 285.62
Use of a CrossFire system: No
Drop of FPS in the confined spaces (buildings/ships): Yes
Server name: Not Server Specific in my case, tried many servers out

The details of my Issue:

I find the FPS lag to be random, not restricted to confined spaces at all.

Example: I will stand my character in one place, out of combat but with enemies in view along with fellow players, and watch my FPS change constantly. For a matter of minutes I could experience 60fps without any problems, but in a matter of minutes I could also experience 15fps and then back up to 40-60, all while standing still and still camera movement. I could then move my character into combat and experience 40-60fps as well as randomly get 15fps, I've tested this scenario many times and the results are random.

Just to be clear:
-I Have turned OFF shadows
-I have changed from low to high to low settings
-I have fine-tuned my graphics card to side with performance
-I have done every mentioned fix in the forumn but have found no solution
-I have also found a slight improvement by messing with the .ini file, but only slight
-Also, my internet speed is not the cause either, its connected nicely.

I know for a fact that I have done my part on my end to achieve best possible gameplay, the problem lies within the game itself.

I do have a suggestion for Devs though: Please put in the option to adjust draw distance, as I think it would provide a way for users to better fine tune their graphic settings.

Berlik's Avatar


Berlik
12.29.2011 , 02:29 AM | #13
Quote: Originally Posted by Ambiorx View Post
Completely deleted the game and reinstalling atm, not going to touch any of the setting and going to try to play at the lowest setting.
If this fps issue isn't resolved soon I'll suspend my account.
yea i think im going to reformat my computer tomorrow , install swtor and check my fps before i install anything else

carrylot's Avatar


carrylot
12.29.2011 , 02:35 AM | #14
Quote: Originally Posted by Berlik View Post
yea i think im going to reformat my computer tomorrow , install swtor and check my fps before i install anything else
Already did this twice, changed nothing. It is Bioware not your computer. The only people who shouldn't be complaining about low fps are people still using 8800 GT's and single core processors with 2 gigs of ram. Any PC using 4 gigs, dual core 2+, and a graphics card with at least 1 gig of memory should be running this game smooth on low settings. Ironically people with the best rigs out there are getting garbage FPS all over the boards.

dremmimax's Avatar


dremmimax
12.29.2011 , 02:35 AM | #15
Return my money!!!!!!

NyyuSecura's Avatar


NyyuSecura
12.29.2011 , 02:45 AM | #16
crafting crew skills in a room, this is how i play the game, if i go outside bam 10 fps...

Gesome's Avatar


Gesome
12.29.2011 , 02:52 AM | #17
FPS:
PvE: 20-80(indoor/outdoor doesn't make a difference, random frame rate drops and stuttering)
PvP: 5-20(All warzones, roguhly 5 when engaged with an enemy, 20 at the start)
Server/s: The Swiftsure, The Bastion.

DxDiag:
Spoiler


Hope this helps, the game seems like it would be fun...
AMD Phenom II X4 840 3.2GHz ---- 4gb DDR3,
ATI Radeon HD 5770 ---- Windows 7 Home 64 bit

Fix it.

Ambiorx's Avatar


Ambiorx
12.29.2011 , 02:54 AM | #18
Did anyone try this allready? I'm reinstalling the game atm but if that doesn't work I'll try this.
http://www.swtor.com/community/showthread.php?t=98469

Gesome's Avatar


Gesome
12.29.2011 , 02:57 AM | #19
Quote: Originally Posted by Ambiorx View Post
Did anyone try this allready? I'm reinstalling the game atm but if that doesn't work I'll try this.
http://www.swtor.com/community/showthread.php?t=98469
I tried it, it helped for PvE a bit enough to make it playable but didn't stop the stuttering etc.
AMD Phenom II X4 840 3.2GHz ---- 4gb DDR3,
ATI Radeon HD 5770 ---- Windows 7 Home 64 bit

Fix it.

Novarg's Avatar


Novarg
12.29.2011 , 02:58 AM | #20
Didn't work. Re-installing the game also has no effect for me.