Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Oricon Story: Mission "The hand that sees"

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Oricon Story: Mission "The hand that sees"

WizardGR's Avatar

08.17.2019 , 05:07 AM | #1
I was doing the story content on Oricon, but to my big surprise, I couldn't finish it.

I entered in the portal normally, but the 2 consoles was blue all the time, without any "hand" to click them.
I reset the quest and went back to the stairs of the tower. (Quest asks to go to the steps for start)
So I entered again with same results.
With some luck I found that I could click the 2 consoles from the right side.
The quest was updating.

I did also the 3rd console to lower the shield, but that didn't worked, even if the quest was updated (watch at the left that the console is active)

Resetting didn't work, so I tried to relog in.
That worked.
The shield was down and I could click the button, with the 2 consoles inactive.

The daily of this quest worked as intended, without any weird circumstances, like above
Click or do not click Refferal link There is no try. (You get 7 days of subscription plus some mambo jumbo things)

Is that a Terminator on Imperial Fleet?

donbelic's Avatar

09.19.2019 , 03:18 PM | #2
I had the same problem and I just logged out and back in, force field was gone.
I find your lack of faith disturbing!

Referal Link