Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Knights of the fallen empire Chapter 1 is Bugged

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Knights of the fallen empire Chapter 1 is Bugged

jmcdonnell's Avatar


jmcdonnell
08.15.2019 , 04:27 AM | #1
help bioware the knights of the fallen empire chapter 1 is bugged whenever i get to the point where arkann is taking me to meet the emperor the games freezes, if u guys could be so kind as to fix this bug it would be much appreciated

SteveTheCynic's Avatar


SteveTheCynic
08.15.2019 , 05:12 AM | #2
Quote: Originally Posted by jmcdonnell View Post
help bioware the knights of the fallen empire chapter 1 is bugged whenever i get to the point where arkann is taking me to meet the emperor the games freezes, if u guys could be so kind as to fix this bug it would be much appreciated
While you're waiting for the fix (given that it clearly affects very few players and you gave no information other than that it freezes during *that* cinematic(1)), try setting your graphics to the lowest possible settings and then trying again. The KotFE cinematics are more demanding on graphics cards than the original game was, and the system requirements have gone up for that and other reasons since the game was released.

(1) Silly stuff like:
* Make and model of computer
* Or make and model of motherboard, CPU, GPU
* Quantity of system memory and GPU memory. You'll need at least 1GB of dedicated GPU memory.
* Operating system and version ("Windows" is insufficient information. "Windows 10 Professional 64-bit build 1904"(2) is more the sort of thing we're looking for.)
* What your graphics settings are now.

(2) That's what I use.
http://www.swtor.com/r/Hg3sV2
To go to Belsavis, you must go to Belsavis.
> @"Biff.5312" said:
> Exercise your whimsy.

jmcdonnell's Avatar


jmcdonnell
08.15.2019 , 01:46 PM | #3
sorry for the lack of detail, whenever i get captured by arcann and hes leading me to the emperor, everytime i get close enough to the door, it goes to initiate the cinematic, turns to the lack screen than freezes, it isnt a problem with my os as i can run World of Warcraft at around 7 or 8 on the graphics setting, im just trying to figure out why its doing that on a high end computer

Adric_the_Red's Avatar


Adric_the_Red
08.20.2019 , 06:51 PM | #4
Quote: Originally Posted by jmcdonnell View Post
it isnt a problem with my os as i can run World of Warcraft at around 7 or 8 on the graphics setting, im just trying to figure out why its doing that on a high end computer
Gonna steal a bit of Steve's thunder here and point out that just because you can run some other game fine doesn't mean this one will run perfectly for you (or vice versa). Your OS is just one piece of the puzzle, and possibly a significant one, depending on what it is and ... all that other stuff Steve mentioned. Seriously, if you want help with your problem, provide the requested info.

And FWIW, I run the game on a PC that is likely a long-fossilized dinosaur compared to yours, and I have never had any issues with any of the cinematics playing. And I run on a custom selection of settings that works out to somewhere around Medium to Medium-High.
"Your deaths are useless if they do not inform". -- The Shroud
My referral link. Click for free stuff.

LiLiIreneK's Avatar


LiLiIreneK
08.31.2019 , 10:30 AM | #5
Thanks for the info. Had the same issues and changing the graphics settings worked to fix them.

Played SWTOR and WoW for years and there was a huge difference in the way the two games ran, not just graphics-wise.

SteveTheCynic's Avatar


SteveTheCynic
08.31.2019 , 12:08 PM | #6
Quote: Originally Posted by LiLiIreneK View Post
Thanks for the info. Had the same issues and changing the graphics settings worked to fix them.
Cool. Thanks for letting us know the advive about low graphics worked for you.
http://www.swtor.com/r/Hg3sV2
To go to Belsavis, you must go to Belsavis.
> @"Biff.5312" said:
> Exercise your whimsy.