Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Unable to progress class mission: Sith Warrior: Ambush!

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Unable to progress class mission: Sith Warrior: Ambush!

nekogunner's Avatar


nekogunner
09.18.2019 , 03:44 AM | #1
I have run into a nasty bug that is not allowing my Sith Warrior to progress the main class story line. I boarded the ship for the mission "Ambush!" and cleared it of all enemies. The bonus secondary mission linked to the primary to defeat 20 enemy NPC's completed. When I reached the bridge the doors opened and a few enemy NPC's were waiting. I defeated them, but presumably the next trigger is bugged as nothing happens. I try to go talk to the Moff on the bridge with his 3 guards but it says I'm not eligible for the conversation.

I've tried leaving instance, returning to my ship, traveling to the fleet, and back. I've tried relogging, exiting and restarting the game, and dismissing/resummoning different companions, but sadly nothing seems to work. I am unable to reset or abandon the mission as both buttons are not clickable.

Please see videos I've uploaded to YouTube at the links below:

https://youtu.be/k3Pk5rrQ-u4
https://youtu.be/pxGUPYZlk18

OwenBrooks's Avatar


OwenBrooks
09.19.2019 , 08:58 PM | #2
Missions are only re-settable in non instanced areas have you tried resetting on say fleet ?

nekogunner's Avatar


nekogunner
09.20.2019 , 11:56 AM | #3
I ended up filing a ticket with support. They said they were unable to reproduce on their end. I logged back in the next day and the trigger had taken.

Not sure what the bug was, but it resolved itself.

\_(ツ)_/