Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Launcher Stuck at 100%. Completely Lost here

STAR WARS: The Old Republic > English > General Discussion
Launcher Stuck at 100%. Completely Lost here

Menlow's Avatar

07.04.2016 , 08:34 AM | #1
Im sorry if this is the wrong section for this kind of problem but im beginning to see red here. As the only option to actually ask for help quickly is apparently writing an In-game ticket which obviously might be a little bit difficult to do when your launcher bugs out every new patch that comes out.

My launcher is stuck yet again at 100% "installing" even tho last time i wanted to update the game i barely was 50% done with downloading the actual patch.

Ive tried:
-deleting "bitraider" folder
-turned off anti virus
-Tried using the "reapair launcher" tool from the support page

But nothing helps. Anyone here might have the same difficulty that hopefully dont include redownloading the whole game?
Because im getting tired of doing that everytime a patch comes out with my slow internet connection