Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

stuck installing game client 274

STAR WARS: The Old Republic > English > STAR WARS Discussion
stuck installing game client 274

Xavierdeleon's Avatar


Xavierdeleon
06.26.2020 , 02:08 PM | #1
My launcher is on the non streaming version and downloads everything up till game client 274 where it gets stuck. The streaming version is no better and gets stuck, and the only solutions to that are to go to the non streaming version and get stuck again. I've already changed the lines in my launcher settings and other posts have said to delete some folders which led to some progress but I'm still stuck at 73% on game client 274.

Bxvx's Avatar


Bxvx
06.30.2020 , 07:08 AM | #2
I had a similar problem a few weeks ago I found some articles where people say to delete all game files and redownload the game. I personally was trying to avoid that being lazy, so one weekend instead of logging out all the way I would sit at the server select screen when I was sleeping or not home and when I got back on I just went right to character select. Then I decided deleting everything and redownloading was probably my last life line so I turned off the pc and went to bed and then when I logged on the next day the patcher actually worked like normal. And I haven't had that problem since, seems like alot of people have the problem cause I found alot of youtube and text articles about ways to fix none of them actually worked for me. Hoping telling my story might help them find a way to fix this problem.