Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Mission BUG - Taris: Bonus Series

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Mission BUG - Taris: Bonus Series
First BioWare Post First BioWare Post

Mojkowski's Avatar


Mojkowski
11.03.2019 , 01:40 PM | #71
It's almoust end of 2019 and Bug still NOT fixed, as a new player im very confuse. It takes YEARS gentelmens!!!, YEARS!!!

TeimurazBezh's Avatar


TeimurazBezh
12.03.2019 , 02:23 PM | #72
Still, not fixed been years now

TrixxieTriss's Avatar


TrixxieTriss
12.03.2019 , 06:49 PM | #73
Quote: Originally Posted by MasterTankar View Post
You guys might want to work on your turn around time for bugs while your at it. Four years is a little much.
Snap

TeimurazBezh's Avatar


TeimurazBezh
12.09.2019 , 12:23 PM | #74
Please fix this bug...

lordbyronkey's Avatar


lordbyronkey
12.17.2019 , 06:12 PM | #75
Just ran into this.

I'm pretty furious about it. Especially seeing that this has been a problem for this long.

I was already sick of the level design on Taris. The way they make you just wander back and forth constantly crossing the same areas over and over again... makes me sick. It got so boring and so transparent that they were just wasting my time and making the game take longer with nothing but aimless travel. I almost unsubbed.

After slogging through it anyway, getting to the end of the quests, I get to the bonus series. Aaaaannnd can't complete it!!!

So after dragging that **** out for THAT long, they can't even be bothered to make sure the quests work??

Dude, this has to be a civil case with some class merit at this point. How many players have been affected by this and lost a massive amount of time only to find out it wasn't worth trying to complete the planet??

At what point should devs run into class-action legal problems for not fixing their games???

This has been a known bug for YEARS and YEARS. As a programmer, I know for a fact this would take a very small amount of time to craft a workaround for if it could not easily be fixed outright. it wouldn't even be hard to fix, something as simple as a warning added to the text of the quest that you need to wait to complete would do it.

It's just pure negligence at this point.

ObiFritz's Avatar


ObiFritz
01.03.2020 , 03:37 PM | #76
I just encountered the Bug and was hoping to find a solution. Its sad to see this post and realise = there is still no solution to it. Great...

qsilverlight's Avatar


qsilverlight
01.05.2020 , 07:36 AM | #77
Huh, seems this bug will never be solved. Seems this forum is designed only for one goal - so people can let off steam. No official response, no bugs solved - neglect of the community and customers - not a cool actually.
P.S. Seems forum's post editor broken too. Nice EA's products quality. D:

knighttcd's Avatar


knighttcd
01.10.2020 , 09:36 PM | #78
Just encountered this bug from 2015, nice job dev.

Baghiel's Avatar


Baghiel
01.11.2020 , 12:43 AM | #79
I have been hit by the same bug, Pub Balmorra. So I reset the particular Bonus Series quest. And now I have both quests required for that one completed... And now both are greyed out, and can't complete/progress that Bonus Series.
Inside everyone there is light, and there is darkness. It is the duality of human nature, inherent in us all. What will it take to bring your darkness to the fore?

SteveTheCynic's Avatar


SteveTheCynic
01.11.2020 , 01:19 AM | #80
Quote: Originally Posted by knighttcd View Post
Just encountered this bug from 2015, nice job dev.
It's not a bug from 2015. I'll add a note of despair to your day by pointing out that the game launched with this bug, in 2011.
http://www.swtor.com/r/Hg3sV2
To go to Belsavis, you must go to Belsavis.
Up the Universe!