Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Black Screen after cinematic intro for Eternal Throne

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Black Screen after cinematic intro for Eternal Throne

Overlordshaman's Avatar


Overlordshaman
05.18.2017 , 04:57 PM | #1
So I got back to the game after playing mostly ESO, and I spent 4 hrs downloading the game, money on a subscription and some Cartel Coins. I purchase the Togruta race (from a starter character where everything is fine), create my character with the boost for Eternal Throne, watch the awesome cinematic intro, see my character on a wasteland for about 2 sec and then the old "in a galaxy far far away" intro starts up and baam enters black screen of death. First time I can see half a planet, and rest black screen, next time I watch... ehm, listen through the whole thing which doesn't work. What to I do? I took the whole day just get to this point, sucks that I have to wait even longer just to play the damn game... kinda feel maby I should be compensated?

SteveTheCynic's Avatar


SteveTheCynic
05.19.2017 , 09:24 AM | #2
Look on your launcher for the letters "ST" somewhere (not in the words "Star Wars", naturally) - if you find them, you are using the "streaming" updater (aka BitRaider). It's a bit of a mess, but that's a conversation for another time. It downloads enough to allow you to play "start-at-1" characters on the default starting planets, and then downloads the rest in the background as you play. Of course, a start-at-65 character or start-at-60 character does not start on the default starting planet, so you'll need to wait with the launcher logged in but the game not launched until it has downloaded everything.

Or play a *new* start-at-1 character while you wait.
http://www.swtor.com/r/Hg3sV2
Buda-buda-buda-buda-buda-buda-CHING!
PEW! PEW-PEW-PEW!
To go to Belsavis, you must go to Belsavis.