Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Game Freezing up on Ossus


Dianni's Avatar


Dianni
12.11.2018 , 04:00 PM | #1
I run my graphics on high with no problems, with the exception of the Assault on Tython end cutscene. I logged in to play the new content. Within five minutes on Ossus scanning, game freeze. Restart game, log in, turn down graphics to low - freeze on cut scene. After 5 more tries I get to the ship - Freeze up.
Basically, the new content is unplayable for me. I am mad so I haven't tried any other stuff to see if it the problem has found its way into other content but if I know SWTOR, it has.

Anybody else having this problem?

LordVladivus's Avatar


LordVladivus
12.11.2018 , 07:04 PM | #2
Yeah. Iím having it do the same. Outside Ossus itís fine. I had the same issue when I first started KOTFE. Those first few missions were a nightmare. The issue cleared up and Iíve not had a problem since. Till Ossus. Lags big time/just freezes.

tracylez's Avatar


tracylez
12.15.2018 , 03:05 AM | #3
Totally the same issue. I have played other toons who haven't reached Ossus and no issues. Customer service so far has been unable to willing to admit their is an issue.

IoNonSoEVero's Avatar


IoNonSoEVero
12.15.2018 , 03:11 AM | #4
Same here. No issues outside of Ossus, but in Ossus the game freezes and crashes over and over again and it always requires a game restart. Tonight I couldn't even get through 30 minutes of dailies without two crashes. The only way I've been able to deal with it is to set the graphics very low. I have a 2018 system so it's not the "outdated graphics card" excuse.

-Spc's Avatar


-Spc
12.15.2018 , 06:34 AM | #5
I have same problems, it's not the game (client) but server side.
Server just stops responding for 10-30 seconds.
Bring back weekly passes ( OPS AND WARZONE ) and loot from bosses and vendors !!
7 Days Referral: http://www.swtor.com/r/GVDQ7k

Lammia's Avatar


Lammia
12.15.2018 , 06:51 AM | #6
Another one here with the same. The game froze on me (2 x cutscenes, and 2 x mid-combat) until I took my settings to low on everything.

I have Intel integrated, which is known for freezing sometimes (2 cutscenes on Nathema, several in KOTET). It never happens when playing vanilla. It's getting worse with each new story bit.
My Art
FIX MALAVAI QUINN CUSTOMISATION IN IOKATH!
This is not the referral you're looking for

Lunafox's Avatar


Lunafox
12.16.2018 , 12:48 AM | #7
I had issues today with freezing up and getting booted out of the game too while doing dailies.
💥The galaxy is ours to grasp. Let us reach!💥

Lunafox's Stories🌙🦊Lunafox's Decorating
Koona t'chuta, Solo?
Quote: Originally Posted by Rion_Starkiller View Post
omg Darth Lunafox in the house

Akata's Avatar


Akata
02.16.2019 , 06:51 AM | #8
Same issue for me, only Ossus game freezes every 5-10 seconds for 2-3 seconds at a time. No issue anywhere else not sure what EA/Bioware is doing on that planet but considering it's the one of the only way to get the new gear this is getting frustrating

UlaVii's Avatar


UlaVii
02.16.2019 , 07:51 AM | #9
This probably doesn't apply to all of you in this thread but there is a bug where having Vette as your active companion is causing what appears as big lag for people. The suggested "solution" is to not use Vette until BW show her some love

http://www.swtor.com/community/showt...62#edit9703562

juicypalpy's Avatar


juicypalpy
02.16.2019 , 12:48 PM | #10
I'm having an issue of the game freezing up during cutscenes as well, but it's on Odessen, not Ossus (haven't made it that far into the story)