Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher Trouble

Nayrue's Avatar


Nayrue
07.07.2016 , 02:17 PM | #1
I don't know if this is the appropriate section to be asking for technical support but the link in the launcher was unhelpful.
so I cant log into the game every time I try it says "this application has encountered an unspecified error. Please try this patch again" not sure what to do please advise

thank you

Ahrngrim's Avatar


Ahrngrim
07.07.2016 , 02:43 PM | #2
The Best Place to ask would be http://answers.ea.com/t5/STAR-WARS-T...ld-republic-en.

For your Problem the simplest solution is probability to delete the Bitarider Folder, this forces an repair.
My referall link: http://www.swtor.com/r/JQgzk7
Find Help at EA ANSWERS HQ English
Finde Hilfe unter EA Answer HQ Deutsch

Adric_the_Red's Avatar


Adric_the_Red
07.07.2016 , 03:02 PM | #3
This sometimes can be due to AV/Firewall settings. Make sure both the launcher.exe and swtor.exe are added to your exceptions list(s). Also, there may be other settings you need to change, depending on which AV/Firewall you are using.
"Your deaths are useless if they do not inform". -- The Shroud
My referral link. Click for free stuff.

Erevan_Kindelar's Avatar


Erevan_Kindelar
07.07.2016 , 03:57 PM | #4
You might also try setting the Launcher to run as Administrator and as an Administrator (those are two slightly different things), because it could be a User Account Control prompt that is trying to activate to ask you to confirm that the Launcher is allowed to do stuff, and that delay is causing time-outs in the application.
In Windows 7, at least, you can right-click on the swtor shortcut, and go to the Properties option on the menu.
Click on the "Compatibility" tab, and at the bottom under "Privilege Level", choose "Run this program as an Administrator". Apply the changes, confirm the change when the UAC prompt comes up, and try it out.
If that does not work, then again right-click the swtor shortcut and go to Properties, and on the "Shortcut" tab, click on the "Advanced" button and put a checkmark in the "Run as Administrator" box. Click OK, then Apply, and confirm the change when the UAC prompt comes up.
It should now either flag a UAC prompt more quickly or not flag one at all, depending on your UAC settings (I really do not recommend changing those unless you know what you are doing ).
And if the Launcher starts working, then try un-doing those suggested changes, and see if the problem returns (it might not, if the problematic process is an update).
I am telling the truth, honestly! I am as honest as the day is long! Besides, I am a terrible liar, everyone can see when I am lying - my lips are moving.
Like most other subs, I have a Referral Link. Clicking it gets you some stuff, and me some stuff too.