Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Taris Bonus Series Can Become Non-Completable

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Taris Bonus Series Can Become Non-Completable
First BioWare Post First BioWare Post

TeimurazBezh's Avatar

12.08.2019 , 01:07 PM | #111
Quote: Originally Posted by EricMusco View Post
Hey folks,

I checked with the team and we are aware of the issue and working on a fix. Unfortunately, addressing it is a bit more complex than we would like and so it is going to be a while until we can get it resolved. I wouldn't expect this to get fixed before 6.0, but we will look to have it fixed in a patch as soon as we can!


Any news ? hopefully It will be fixed for next patch

lordbyronkey's Avatar

12.17.2019 , 06:33 PM | #112
Just adding to the pile here.

I just ran into the bug on Taris. I did "The Missing Link" before I talked to the NPC in question. Now the objective is greyed out in the quest log, and I can't do anything more with the questline. Same as everyone else.

PLEASE fix this EA. Even just putting warning text in the description of the quest the missing link that says "do not complete this quest until you have reached such and such point in the bonus series quest."

That is literally all it would take to have avoided this for a LOT of people and it would be a non-issue for most. Now that you let it go on this long... think how many people this has turned to the dark side out of pure anger?

As it is, I'm pretty peeved about this and thinking of unsubbing until I read that this has been fixed. I'm a completionist, so this drives me absolutely bonkers, and if this can happen on other planets... it's totally absurd and SOMETHING needs to be done about it.

rinrinbrigade's Avatar

12.17.2019 , 06:51 PM | #113
Stuck at Engineer Ferron... I did his quest when it became available because why wouldn't I, didn't know this was a problem, and now I'm unable to complete Taris: Bonus Series. Any idea/update on if/when this will be fixed? Post about them being aware was in July... Now it's almost the end of December and past 6.0

Sepp's Avatar

12.26.2019 , 12:09 PM | #114
Bugged at Engineer Ferron for me. Any update on a fix?
Collectors Edition
Revan Test Server Veteran
HK-47 Test Server Veteran

Jaxar_Kenadou's Avatar

01.25.2020 , 02:25 AM | #115
As of today, this issue has still not been fixed

Spikanor's Avatar

01.25.2020 , 03:08 AM | #116
Quote: Originally Posted by Jaxar_Kenadou View Post
As of today, this issue has still not been fixed
same like the other issue's that not have been fix for a long time and have been report on the forum that are still broken.
Get Free 7 day's sub with my Referral Link

Here ->

Corkej's Avatar

02.04.2020 , 04:45 PM | #117
Also happened today, completed the chain, but then it wanted me to talk to Engineer Ferron again, but cannot. Reset the quest, talked to Vealo again and then now it wants me to talk to Mola, but also greyed out.

VagrantWhisper's Avatar

02.06.2020 , 10:33 PM | #118
Also stuck with Engineer Ferron not being accessible to re-complete the previously complete "Power Flux"

sandalle's Avatar

02.21.2020 , 01:45 AM | #119
Still an issue, just posted a bug report about it and was pointed to this thread. :'(

Tofu_Shark's Avatar

03.12.2020 , 12:44 AM | #120
I have a related update to this. A similar bug also applies to phased bonus missions.

I was running story on an alt on Republic Balmorra, and I was on the exploration mission, Food Chain. I got to the final phase of the bonus mission attached to that and I didn't notice an alert message, so I wanted to confirm there wasn't one before I submitted a ticket on it. When I reset the misison, the little droid drops down with the announcement "Bonus Mission Objective Updating..." but my Mission Tracker nor Log updates. I lost the bonus mission completely. My actions didn't contribute to progressing it again, and there is no indication of objective locations on the map anymore. Resetting or abandoning the main mission and picking it up again yields the same results.

I got a response from CS, but they seem to think I was reporting the Bonus Series bug for Empire Balmorra. The quality of these CS agents is sometimes downright atrocious. I don't even think they read my ticket, or they are offshored workers with one-track minds.

Don't reset or abandon a phased bonus mission that is on the final phase.
If I've been helpful or you liked my post, click my referral link
Also if you just want some free stuff.
Of course, I get something out of it too.