Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

The user agreement

First BioWare Post First BioWare Post

LordRashu's Avatar


LordRashu
05.23.2017 , 02:05 PM | #1
Hello for some reason the End User Access and the License agreement has began to pop up every time I start up the game... I can check the boxes and get into the game, but does anyone know why this keeps happening every time I open up the launcher?

EricMusco's Avatar


EricMusco
05.23.2017 , 03:06 PM | #2 Click here to go to the next staff post in this thread. Next  
Quote: Originally Posted by LordRashu View Post
Hello for some reason the End User Access and the License agreement has began to pop up every time I start up the game... I can check the boxes and get into the game, but does anyone know why this keeps happening every time I open up the launcher?
I will send this over to the team and see if we can figure out what the issue is.

-eric
Eric Musco | Community Manager
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.]

LordRashu's Avatar


LordRashu
05.23.2017 , 04:57 PM | #3
Thank you

Meshla_Naast's Avatar


Meshla_Naast
05.23.2017 , 06:44 PM | #4
Thank you!
Callysta Gseran
Lvl 65 Sage
Guild: <Your Phase or Mine>
Server: Shadowlands

RaijiMagiwind's Avatar


RaijiMagiwind
05.23.2017 , 07:38 PM | #5
Thank you. Hope to hear something about this soon...

Wonder if this has something to do with the recent Windows 10 Creators Update, as I know I have seen several issue pop up over the past week since the update went out. Maybe something to check into at least.. at least for any of those who are Windows 10 users.

I know this seems to have been one of a handful of issues SWTOR folk have been having since that update...at least from what I have seen

MandFlurry's Avatar


MandFlurry
05.24.2017 , 04:15 AM | #6
Eric there has been a Lot of /bugs, even ones i haven't reported because i don't want to be a bother to people. I never had these problems before til' now.

Also, we need the be able to download the Full game to another Hard drive HDD instead of having it on 2 Hard drives making problems..
Got CE on 7/20/11
Canderous Ordo ServerRegulator
Referral for Star Wars Goodness
http://www.swtor.com/user/ce/3k4e

OwenBrooks's Avatar


OwenBrooks
05.24.2017 , 04:22 AM | #7
Quote: Originally Posted by MandFlurry View Post
Also, we need the be able to download the Full game to another Hard drive HDD instead of having it on 2 Hard drives making problems..
Can you elaborate ?

The easiest way to install the game anywhere even not using the setup file is to create a folder anywhere on any drive you want the game on. eg. f:\games\swtor\

Then run this repair utility which is just a self extracting archive and extract the launcher files directly into that folder.

Create a desktop shortcut for launcher.exe should be all that is needed.

If the game doesn't download use the non streaming launcher settings and the game should be gold.

AaronDraguinil's Avatar


AaronDraguinil
05.25.2017 , 11:40 AM | #8
I have the same bug. Each time I try to log in, I am forced to agree to the user agreements all over again.
Additionally, none of my customized GUI layouts are saved from login to next login. Each time, I need to reset it to extended toobars, uncheck nameplates, and allow same class permissions.

LordRashu's Avatar


LordRashu
05.25.2017 , 02:00 PM | #9
same thing here but my bars are fine

Matrxhasyou's Avatar


Matrxhasyou
05.25.2017 , 05:12 PM | #10
Just installed client a few days ago. Windows 10 creator update. No antivirus installed beyond built-in Windows features. Applications running as administrator (launcher and client). Read/write permissions set up correctly in Documents and Settings as well as game directories.

Both agreements pop up every time I launch the game, whether it's a reboot of the PC or launching multiple times without power cycling.

Don't know if it's related, but.. I started playing on Tython as soon as "ready to play", but some animations were off, even after the full client finished downloading. Restarted the game and everything appeared correct, minus the terms agreements popping up every time. Maybe something got stuck since I started playing before the client was done downloading? I only mention this as a possibility because other things were acting up too.