Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Subscription not activated

First BioWare Post First BioWare Post

Infestion's Avatar


Infestion
02.07.2021 , 02:38 PM | #1
I am a subscriber and get billed every month for a subscription for my own account and another account. The payments went out this month on the first and second for each account. I log into my account and it is showing that I am a preferred status member, even though the payment went through 5 or 6 days ago. This is the first occurrence of this issue I have had. The other account doesn't have this issue. Can I get some help on this issue? Im not sure where to go since the US phone number for support doesnt work

CommunityTeam's Avatar


CommunityTeam
02.09.2021 , 04:47 AM | #2 This is the last staff post in this thread.  
Hi Infestion,

For account and billing issues, you need to directly contact our support team by phone. Here is our article on how to do that: How to contact Star Wars™: The Old Republic™ (SW:TOR) support.
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.]

mike_carton's Avatar


mike_carton
02.09.2021 , 06:47 AM | #3
Can we get a short sticky post (possibly locked from the beginning) on who to contact for what kind of issues? We keep getting these questions.
Click this SWTOR link to create an account or log in and we both earn rewards (7-day Free Subscription, 1 Free Server Transfer, Free JumpStart or Preferred Bundles).